Forums

reCaptcha not appearing

dnigra 20 Aug, 2013
Hi,

I'm using chronoforms 4.0 RC3.5.2, Joomla 2.5.

I can't get a Recaptcha to show. I have done this before on other sites. I load the recaptcha first thing in the OnLoad event. I check the recaptcha in the onsubmit event. I have a custom element with {ReCaptcha}.

I generated new keys for the site and copied those into the form. The same keys work in the Joomla form that shows when you click "I forgot my username" in the login module - recaptcha displays nicely there.

Any ideas? Thanks......
GreyHead 20 Aug, 2013
Hi dnigra,

Everything you describe here sounds perfect . . . Please post a link to the form so I can take a quick look.

Bob
dnigra 20 Aug, 2013
I replaced the Recaptcha with a captcha in the form because we went live and I didn't want to be without, so that's not much help, I'm afraid. The site is vecnet.org... you can see the recaptcha in the "forgot my username" page if you like.

Is there something else I should be checking? Some site setting in the chronoforms code that I should verify points to the right place?
GreyHead 21 Aug, 2013
Hi dnigra,

That's the Joomla! ReCaptcha and, as you say, not a lot of help.

There is sometimes a problem with the Joomla! CSS that places the ChronoForme ReCaptcha up at the top left hand corner of the page where it can be out of sight. Is that happening with your form?

Bob
dnigra 21 Aug, 2013
Hi Greyhead,

Yeah, I've seen that sometimes, but in those cases I've seen a border outline where the ReCaptcha should be. That's not happening in this case.

Here's my best guess where the problem lies: We've been developing this site on a dev machine. Both the dev and the production machine have changed domain names during that process. We then copied all the content from the dev site and stood it up on the production machine. The chronoforms content was included in that... I did not backup the forms from dev and reinstall on production.

I'm wondering whether the chronoforms install on the production site has some setting that is at odds with what we copied over from the dev site. I'm going to backup the forms, uninstall chronoforms, reinstall it and then the forms. I'll let you know what happens. If you have another idea, let me know.

Thanks again for all your help.
dnigra 21 Aug, 2013
Uninstalling and reinstalling Chronoforms was not the answer. It's apparently a security issue.

I just now noticed that Firefox was showing the half-gray shield in the address bar. If I click on that and choose 'Disable protection on this page', the ReCaptcha shows in all its glory. Ditto for Chrome and IE; if I allow unencrypted content, the ReCaptcha shows.

I don't think that it's anything to do with the site security settings, because I do get the ReCaptcha on the "forgot my username" page.

Any ideas what to do next?

Many thanks.
GreyHead 22 Aug, 2013
Hi dnigra,

You site is using https ?? In that case the ReCapthca URLs probably need to be https too. Could that be the problem?

Bob
dnigra 22 Aug, 2013
Hi Greyhead,

Yes, the site is https, so I had the same thought. But in the OnLoad Recaptcha action when I set the ReCaptcha server to https, I get an "invalid referer" error in the form where the ReCaptcha should be. The ReCaptcha secure server is already set to https.

If no one else is having this problem, it must be me - well, my site settings. I don't see any other complaints like this out there. I will go have another talk with my sysadmin.

Thanks again for your help.
GreyHead 22 Aug, 2013
Hi dnigra,

There's a Google Tip sheet here that might help.

Bob
dnigra 29 Aug, 2013
Just an FYI, the problem was on our site, not a Chronoforms issue at all.
Thank you again for your help.
This topic is locked and no more replies can be posted.