Forums

Chronoform 3 - Anti spam

GreyHead 20 Sep, 2012
Hi Damir,

This is an odd message as it talks about email as well as imageverification. Do you have Serverside validation set up? If so what code are you using?

Bob
damir 20 Sep, 2012
Hello. thank you for fast reply.

I have entered in field Error message:
"You have entered an incorrect anti-spam text. Please enter e-mail address and anti-spam code again."

Well, You are right, the part "e-mail address" could be removed from the message.
But I think that is not a problem. Problem is that although correct anti spam code is entered it is rejected by validation function.

Regards,
Damir
GreyHead 20 Sep, 2012
Hi Damir,

By all means email or PM me the site URL and a SuperAdmin login and I'll take a quick look.

Bob
GreyHead 20 Sep, 2012
Hi Damir,

I've spent about an hour on this and I cannot see what the problem is. It looks as though the page may be being cached - but I can't see any caching set up :-(

I built a new test form that behaves in the same way; I also tested ReCaptcha and that has exactly the same problem. I also turned the Check Token off in case that was the problem - it isn't.

At the moment I'm baffled; I do remember occasional problems with this in CFv3 but I don't have any other solutions.

I suggest that you add a test question of some kind and verify it in the ServerSide validation box. That may be quicker and easier than debugging this problem.

Bob
damir 21 Sep, 2012
Hello Bob
Thanks for the effort you put solving this problem.

Do you think upgrade to newest version might help?
Please could you send me on e-mail example form with Server Side verification.

Thank you in advance.

Regards,
Damir
GreyHead 21 Sep, 2012
Hi Damir,

Upgrading to the latest version of ChronoForms v3 might help but I can't be certain. This isn't a problem that I remember seeing before. It would be better to upgrade to CFv4 but to do this you'd need to enable the MooTools Upgrade plug-in which might cause other problems on your site.

I did notice that the Joomla! 1.0 legacy options are installed on the site. It's just possible that those are causing a problem but again I can't be certain.

I'd suggest that you add a honeytrap verification. Put a text input into your form and hide it with CSS, then use the ServerSide Validation on the Anti-Spam tab to check if it has a value - if it does then reject the form. This works on the basis that spam-bots put entries into every input they find but human users can't see this one so leave it empty.

Bob
damir 21 Sep, 2012
Hi Bob.

OK, thank you. I will try to do as you sugested.

Best regards,
Damir
This topic is locked and no more replies can be posted.