Can't Set "From" email address

wlwan 08 Jul, 2015
I have enter the the "from email" in the cf v5 setting, but it just ignore it and use the SMTP username as "from email", any idea what's wrong?
(i have double checked the setting in Global Configuration, but fail as well)
or any way i can set the "from email" in somewhere else?
GreyHead 08 Jul, 2015
Hi wlwan,

You can set it in the Email action settings. Please make sure that it matches the site domain to stop the emails being marked as spam.

wlwan 08 Jul, 2015
Dear bob,
I did it as well, but somehow it fails....
And I also double check the php.ini and the "sendmail_from" is correct....

Moreover, I have a quick test > to change the smtp user name (I use gmail as the smtp, so I change the username as another gmail account). Then I try to re-send the same form, find it the "from email" is updated to the new gmail account.

Is there any reason the "from email" stick to the smtp username even though I have all those setting in php.ini, joomla globe config, cf v5 setting and email action?

And, any action I can overwrite the "From email" to make it work?

GreyHead 08 Jul, 2015
Hi wlwan,

Please remove any settings from the CFV5 settings (the ones from the icon in the toolbar); then drag a Debugger action into the On Submit event, then submit the form and post the debug - including the 'dummy emails' results here.

wlwan 09 Jul, 2015
Have remove the from email and from name @ cf v5 setting, but keep those @email action:


    [option] => com_chronoforms5
    [chronoform] => AxxxContact
    [event] => submit
    [title] => Miss
    [company] => test
    [name] => test
    [position] => test
    [email] =>
    [phone] => 23432
    [subject] => feedback
    [interested] => Array
            [0] => Trading and Settlement Solutions for Global Securities
            [1] => Order Routing Solutions

    [comment] => testtesttest
    [button10] => Submit
    [fromemail] =>
wlwan 09 Jul, 2015
Some more update....
Just know that the reason behind is: GMail not allow anyone to change the "From address" and it will overwrite whatever setting on it + replace it with the actual account address use in smtp user. As a result, I dont think i can change it if i keep using gmail.

I have use another way to make it work -> to use phpmail instead of smtp for the mail service.

so i think i better close this thread. thanks for your time.
This topic is locked and no more replies can be posted.