Dynamic cc email causes form to not send?

pgrgrl 29 Apr, 2015
I have a form that I created and I tested it with just simple email settings and it worked fine. After I added a dynamic cc so that the user filling out the form would also get a copy of the email form, it caused the form to not work. On submit, it would just reload the form with the contents that the user entered. Do not see the success message, and no emails sent.

When I take out the Dynamic CC then the form works as expected. How can I make it work so that the user is also copied using the dynamic cc?
GreyHead 29 Apr, 2015
Hi pgrgrl,

How exactly do you have the Dynamic CC set up?

I recall one report of something similar a while ago but I though that had been fixed.

pgrgrl 29 Apr, 2015
In the e-mail setup, advanced tab, the Dynamic CC says "Comma separated list of fields names to contain CC addresses". The name of the field where the user enters their e-mail address is called email so I put email in that section.

The rest of the email settings I have entered under the basic tab, with a regular To, From, From Name, Subject.
GreyHead 02 May, 2015
Hi pgrgrl,

I tested for myself and it appears to be working OK.

Please drag a Debugger action into the On Submit event, then submit the form and post the debug - including the 'dummy emails' results here.

pgrgrl 02 May, 2015
Well for some unknown reason it works now. Before when I tried to debug, it would not even show me the debug info, it would just reload same form page with the user entered info in the fields. No actual submit, no loading to message page and no emails or debug info.

Thank you and sorry to have wasted your time on it. I can't think of any other reason why it happened for anyone else who might experience the same problem.
pgrgrl 01 Jun, 2015
Okay, this is a problem again. One of my users reported that the form does not submit.

I removed the dynamic To: in the email. Still does not work.

I removed Honeypot, and the database save thinking those could be wrong. Still, the form does not submit. It reloads the form, with the user's data still in the form. I cannot run debug because the form does not get to that point where it returns the results.

All of my other forms work fine. All I can figure is that it is a caching problem? This form is in an area just for registered users. And I had to enable caching on my site to solve other issues I was having.
GreyHead 01 Jun, 2015
Hi pgrgrl,

The ChronoForms HoneyPot won’t work with caching enabled - it relies on the form loading a token that is linked to the current user. If a cached version is loaded then the token will never match.

I think that NoCaptcha will work (I'm not certain) and so will a 'classic' HoneyPot - that is a text input that is hidden with CSS, When the form is submitted you check to see if a value has been added, if it has then it must have been a bot.

pgrgrl 01 Jun, 2015
Awesome, thank you!!
This topic is locked and no more replies can be posted.