Save Failed when fields or validation are present.

francomedia 24 Sep, 2014
Any advice in solving this problem would be appreciated, sorry if it's been addressed but I couldn't find anything.

I created, set up, and tested a 5 field contact form on a local copy of a website (using MAMP). It all worked great.

After I installed ChronoForms on the production version and used backup/restore to copy the form over, it worked but I could not save the form. It sends me back to a blank form (New Form......) and the following messages are displayed:

Save Failed
A form title is required and should NOT have any spaces or special characters.

When I create a new form, saving works if I only give it a name, but when I add any fields or validation it does the same thing (gives me a blank form and the same error message). was the only FAQ I found but doesn't seem to reflect my problem. I'm not redirected back to the main page, and I only have a couple inputs. I'd like to get a second opinion before I try to muck around with server configuration. I'd prefer not to do that at all.
francomedia 24 Sep, 2014
Update: it's happening on a fresh Joomla install on the same server. (Joomla 2.5.25)

Should I be looking into the same PHP configuration settings as mentioned here?
francomedia 25 Sep, 2014
Turning off Safe Save seems to have fixed the problem.

I'd be interested in knowing why that would be causing issues.
GreyHead 27 Sep, 2014
Hi francomedia,

I don't know :-( Safe Save uses Ajax to save the data in several separate chunks - I guess that something on the server blocks that. Could be a security setting, or possibly a JavaScript conflict somewhere on the Admin page, or something else . . .

francomedia 29 Sep, 2014
Thanks Bob, thats good to know.

This topic is locked and no more replies can be posted.