Dynamic Email To using Session Variable

wayne.regehr 31 Dec, 2013
Joomla 3.2.1 Stable
ChronoForms 5.0RC2
K2 2.6.7

The goal is to have a standard Contact Form where a user can update required fields leveraging K2's front end editing feature via Extra Fields (no administrator panel access necessary).

In my K2 template, I have set the Extra Field value as a Session Variable. Then in ChronoForms, under the Code tab I have changed it to Custom (from Wizard). Here I have a simple echo statement that displays my email address (K2 Extra Field) properly on the front end. This was done to ensure the session variable is being passed.

Next I created a hidden field where I set the value equal to my session variable. Then under the Setup tab, and the Email action, I set the Dynamic Email to the field name of my hidden field (where my variable is being set).

When I check the front end, I received an error saying I must specify at least one valid email. So I attempted the same with a visible field instead of hidden, and indeed there are stripped characters.

Is there another way I can pass my session variable to be used as the Dynamic Email value? Any solutions or alternatives would be greatly appreciated. Also if you would like to see my code, just let me know.
GreyHead 01 Jan, 2014
Hi wayne.regehr,

I don't know about CFv5 but CFv4 didn't strip characters so one approach would be to check what is doing that and turn it off. (We've seen at least one system plug-in that can do it.)

Otherwise you might pass the user_id instead of the email, then look up the email in ChronoForms.

wayne.regehr 02 Jan, 2014

Thanks for the suggestion. I tried a table lookup based on item id and eventually got my email address. However as soon as I attempted to use the email output as the fields value I got the same result.

After inspecting the code output, I realized that the system plug-in Email Cloak was the culprit. Once the plug-in was disabled, my email value was coming through just fine.

Just thought I'd update this post in case it helps someone else out.

Thanks for the feedback Bob!
GreyHead 03 Jan, 2014
Hi Wayne,

If you want to use the Email Cloaking plug-in it needs to run before the ChronoForms plug-in. Please see this FAQ.

This topic is locked and no more replies can be posted.