Forums

I lost information in several files: HELP

AntonioGraca 11 May, 2013
Hello
I use the ChronoForms about a year, I have in same site about 50 forms and had never happened what is happening now.
Happened with 2 forms, maybe they had corrupted and I lost all the information. I made it again and lost the information again.
Afater saving, the form starts by getting unconfigured and then loses event information...
Before I update PHP to 5.3.1...
The problem happened before and after the mysql have been updated on the server...
How can I solve the problem? Does the ChronoForms or the problem is the database I'm using? The problem is in server?
Can I update the ChronoForms without losing what I've done?

Thanks
António Graça
GreyHead 11 May, 2013
Hi António,

That image is too small to read but it looks as though there is some text at the right hand side that might give you a clue about the problem.

This FAQ might also help.

Bob
AntonioGraca 14 May, 2013
Hi, Bob
I send the image with the error and with more definition. But, I canot see any information about the error..

I change the configuration in server:

suhosin.get.max_vars
suhosin.post.max_vars
suhosin.request.max_vars

The max_input_time to 30 and post_max_size to 128M.
mod_security is off.
I need to make any more changes?

Thanks for your help

António Graça
GreyHead 14 May, 2013
Hi Antonio,

Thanks, now I can see that it is just the title of the Actions at the left there. But the page layout is still broken so I suspect that there may be a problem in one of the elements in the Preview box. Please take a Form Backup using the icon in the Forms Manager - if you can - and post it here (as a zipped file) or PM or email it to me and I'll take a closer look.

Bob
AntonioGraca 14 May, 2013
Hi, Bob

I made the sugest changes in server and... I made the forma again and ist ok. Bu I delete the form with errors.
Sorry 😶

I hope not, but if it happens again I'll send you the backup.

Thanks
AntonioGraca 04 Jul, 2013
I Bob! Im back, again!

I canot change this form. When I try save the form, return to panel control of joomla and dont save. In the past I asked to change these settings on the server and they did.

suhosin.get.max_vars
suhosin.post.max_vars
suhosin.request.max_vars
PHP 5.3.9 re-introduced max_input_vars as a php.ini file setting with a default of 1000 if it is not explicitly set.
There is also a max_input_time setting but that defaults to -1 i.e. 'off'.
And post_max_size is also a possibility if it is set very low for some reason.



Any idea?

António Graça
GreyHead 04 Jul, 2013
Hi Antonio,

And what are they set to now?

Bob
AntonioGraca 04 Jul, 2013
Hi, Bob
In 13/05/2013 the guys of server change configation to:

suhosin.get.max_vars
suhosin.post.max_vars
suhosin.request.max_vars
The max_input_time is defined to 30 and the post_max_size wose defined to 128M.
mod_security at momemt is off.



I think still the same configuration...

Thanks fo your support

António Graça
AntonioGraca 04 Jul, 2013
Hi Bob

The guys of server comfirm: Actualy, the configuration is the same.

suhosin.get.max_vars
suhosin.post.max_vars
suhosin.request.max_vars
The max_input_time is defined to 30 and the post_max_size wose defined to 128M.
mod_security at momemt is off.



António Graça
GreyHead 04 Jul, 2013
Hi Antonio,

There are no numbers in there so it makes no sense. What do you see on the System Info tabs in your site admin?

Bob
GreyHead 04 Jul, 2013
Hi Antonio,

It's not in ChronoForms. Please check the Site Admin | System Information | PHP Information page so see what settings are in use for the Suhosin settings (if Suhosin is installed) and for max_input_vars.

Bob
AntonioGraca 04 Jul, 2013
Sorry, sorry, Bob
I dont read well... 😶

php.ini file:
date.timezone =ETC/GMT+1
safe_mode = off
post_max_size = 128M
upload_max_filesize = 128M
max_execution_time = 60
max_input_time = 30
memory_limit = 128M
suhosin.get.max_vars = 2000
suhosin.post.max_vars = 2000
suhosin.request.max_vars = 2000
extension=memcache.so

António Graça
GreyHead 04 Jul, 2013
HI Antonio,

No max_input_vars setting? So your PHP version is less than 5.3?

Try putting the suhosin settings up from 2000 to 3000.

Bob
AntonioGraca 04 Jul, 2013
Hi, BOB
Version PHP 5.2.17
I Ill try the suhosin settings to 3000

Thanks
AntonioGraca 04 Jul, 2013
Hi Bob

I setting the suhosin.get.max_vars = 3000, suhosin.post.max_vars = 3000 and suhosin.request.max_vars= 3000 and not fix the problem...😟

And what about max_input_vars setting? My version php is 5.2.17. Is not possible to set this parameter? I need update to 5.3 version php?

Sorry about I spending your time...


Thanks

António Graça
Max_admin 14 Jul, 2013
Hi Antonio,

Any news ? please try to set the limit to even more than 3000, maybe you have already exceeded that, also please make sure to restart the web server service after doing the change.

if it still doesn't work then maybe you can take a form backup and edit it on your localhost then restore it online again.

Regards,
Max
Max
ChronoForms developer...
Did you try ChronoMyAdmin for managing your Joomla database tables ?
AntonioGraca 24 Jul, 2013
Hi max.
I increase 3000 to 4000 the falowing parametrs:

suhosin.get.max_vars = 4000
suhosin.post.max_vars = 4000
suhosin.request.max_vars = 4000

The service was restarted and remains the same problem: one (specific) the form in administration dont save the change. But wok fine in front.

I dont know nothing about

edit it on your localhost then restore it online again.


Please, show me the way...

Thanks
António Graça
AntonioGraca 24 Jul, 2013
Hi, max

My actual settings of php.ini:
date.timezone =ETC/GMT+1
safe_mode = off
post_max_size = 128M
upload_max_filesize = 128M
max_execution_time = 60
max_input_time = 30
memory_limit = 128M
suhosin.get.max_vars = 4000
suhosin.post.max_vars = 4000
suhosin.request.max_vars = 4000
extension=memcache.so

And what about max_input_vars setting? My version php is 5.2.17. Is not possible to set this parameter? I need update to 5.3 version php?

Thanks
António Graça
Max_admin 25 Jul, 2013
Hi Antonio,

I'm out of ideas, smaller forms work fine ?

if you don't have the "max_input_vars" setting then you don't need to change it.

Maybe you can ask your host admin if there is some error generated which may give us a clue ?

Last thing would be:

if it still doesn't work then maybe you can take a form backup and edit it on your localhost then restore it online again.



Regards,
Max
Max
ChronoForms developer...
Did you try ChronoMyAdmin for managing your Joomla database tables ?
GreyHead 25 Jul, 2013
Hi António,

If you aren't already doing so, please check the suhosin settings on the Site Admin | System Info | PHP Info tab to make sure that the settings you are seeing are the ones that are being applied to your site.

If you have PHP 5.2 then max_input_vars probably isn't a problem; as the FAQ says, it wasn't until PHP 5.3 that it has default setting of 1000 that does cause problems.

Bob
AntonioGraca 25 Jul, 2013
Hi, max
Hi have around 60 forms in my site. All work fine, except one (the biger of them)...

The guys in host service dont found none error in server...

if it still doesn't work then maybe you can take a form backup and edit it on your localhost then restore it online again.



I do not know how to do this, or am I not understanding what you propose to do ...

Regards
António Graça
AntonioGraca 25 Jul, 2013
Hi, Bob

I think is a good question...

Until now, only check the set in php.ini. But, I'll check in server.

Thanks
António Graça
GreyHead 26 Jul, 2013
Hi António,

You can check in the Site Admin with the tabs I posted.

Bob
AntonioGraca 27 Jul, 2013
Hello Bob

You play in lottery? So if we do not play, you should. Bingo! Suhosin settings were not reflected on the website. After several attempts and several errors, there info.php already has the necessary settings for everything (I hope) can work well. Well, in this momemt nothing made sense but you was right.
By now I can make changes to the form that gave error.

(many)Thanks Max and Bob
Ps Bob, do not forget to play the lottery, it can win!

Best Regards

António Graça
GreyHead 27 Jul, 2013
Hi António,

Great - well found! No I don't play the lottery :-(

Bob
AntonioGraca 24 Oct, 2013
Hello, Bob
Several times this has happened to me. In the joomla administration, in the form just the preview is visible (see pictures) and dont have anymore access to events, etc.. However, if I click on the Test Form form ist ok. I think it is a problem when loading the forms in the administration joomla.
I will send you a PM with the php settings.
ps. I canot switch on suhosin, but the rest o configuration its ok (I think).

Thanks
AntonioGraca 16 Jan, 2014
Hi, Bob

I have several problems when I try to submit a large form to a table in DB. When I try to record a large form in table, the form stay in same way, dont record and dont close...

To try solve this problem, I ask the campany server if is possible to setting max_input_vars to maximum. The guys setting max_input_vars to 5000 (before is 3000) but dont solve the problem.
The php is 5.4 and dont suhosin running because return several error in site.
how can I solve this problem?

Thanks
GreyHead 17 Jan, 2014
Hi Antonio,

Please check the Site Admin PHP Info tab and make sure that the max_input_vars setting is actually being changed. Please see this FAQ

Bob
AntonioGraca 21 Jan, 2014
Answer
Hi, bob
max_input_vars is now 7000 (!) but the problem with record changes in forms was not solved. In same time, I have several problems with preview of form. Is desconfigured. Even a small forms. See the picture, and please, see the form in atachment.

Thanks

António Graça
AntonioGraca 21 Jan, 2014
One more detail

Is no possible to put suhosin on in server because the suhosin is not compatible (for now) with php 5.4.

"There is no Suhosin for PHP 5.4. This means we would be stuck at 5.3 and cannot ship the most recent packages which is one of the goals of Arch Linux." "To not break compatibility on minor updates the current version in [extra], PHP 5.3.11, includes a patched version of Suhosin; the last official one was dedicated for 5.3.9."

In https://pierre-schmitz.com/php-5-4-1-in-suhosin-out/



So, I canot solve this problem trough the activate suhosin.
Thanks
This topic is locked and no more replies can be posted.