Fatal error: Call to undefined method HTML_ChronoForms::load

haujo01 18 Dec, 2012

I am trying to use the Multi File Upload Widget. So this is what I tried.

On the Elements tab drag a copy of the widget from the Widget elements group into the Preview box.
Set the element name - including the [], the number of file uploads you want to allow and any other settings you need.
On the Action tab drag an Upload Files action into the On Submit event.
Configure the Upload Files action as normal adding the name of the Multi File Upload *without the []* in the Fields Configuration box with the file types and also on the Advanced tab in the Array Fields box.
If there are no other File elements in your form you will need to add enctype="multipart/form-data" into the Form tag attachment box on the Form General tab (click the Form Name link in the Forms Manager to open it).

I do this and when I view the form I get nothing.
I add a show html and I get this.
Fatal error: Call to undefined method HTML_ChronoForms::loadWidget() in /home/content/17/4709517/html/mb/wordpress/administrator/components/com_chronoforms/form_actions/show_html/cfaction_show_html.php(142) : eval()'d code on line 2

what am i missing?
GreyHead 18 Dec, 2012
Hi John,

It's working OK here with the latest release of ChronoForms.

The missing class is defined in components\com_chronoforms\chronoforms.html.php at line 52 in my version. You might check that the code is there in your copy
public static function loadWidget($form, $type, $params = array()){
  $widFile = JPATH_SITE.DS."administrator".DS."components".DS."com_chronoforms".DS.'form_widgets'.DS.$type.DS.'output_'.$type.'.ctp';
. . . 

Do you get the same error if you click the Test Form icon in the Form Wizard?

haujo01 18 Dec, 2012

I checked line 52 in chronoforms.html.php. The function was not there. I was using the latest 4.0 for 1.5 on your site labled It has the widget but not this function. I took the chronoforms.html.php for the 1.6 dowload and now it works.
Thanks again for the quick response!
GreyHead 18 Dec, 2012
Hi John,

Sorry about that, I guess that Max has his versions slightly out of sync :-(

This topic is locked and no more replies can be posted.