Forums

Form not showing and no database created

mkroeks 02 Oct, 2012
Used the Wizard to create a form,
saved it, but it gives neither preview, nor shows in article.
Also, after Create Table, no table is created or listed.

Using Joomla 2.5.7. and Chronoforms 4.0 RC3.5.1
on United-domains.de, PHP 5.3.1, Safe Mode On, 64MB Max,
only no additional parameters by mail.

Would appreciate help.
GreyHead 02 Oct, 2012
Hi mkroeks,

Please see this FAQ for the form visibility.

The most likely cause of the Create table not working is either na invalid input name or an incorrect TYPE setting (e.g. a TEXT with a length). Please drag a Debugger action into the On Submit event, then submit the form and post the debug results here.

Note: if you are using the Easy Wizard you can turn on Debug on the Others tab.

Bob
mkroeks 02 Oct, 2012
Very strange.

After I switched on the DEBUG option, the form appeared.
It also appears after switching the option off.
[SOLVED] No debug messages appeared, but...
Sollution: must be also in ACTIONS

- [SOLVED] A dropdownbox does not allow the first item to be selected. It sais Please choose a value
Sollution: Value for ShowEmpty must not be empty.


- [SOLVED] A checkbox sais This field is required despite it being checked.
Sollution: FieldDefaultValue must not be empty

- [SOLVED] The creation of a database table still fails without any error message, but with Table successfully created.
Sollution: The creation of DB does not automatically connect the table. This must be done in the ACTIONS in the Wizzard.

- QUESTION:
How to get an email sent to a dynamic address ONLY? It seems there is always a static email address required afaik.
GreyHead 05 Oct, 2012
Hi mkroeks,

You should be able to specify only a Dynamic To Email address provided that there is a valid email address in the form data.

Please drag a Debugger action into the On Submit event, then submit the form and post the debug - including the 'dummy emails' results here.

Note: if you are using the Easy Wizard you can turn on Debug on the Others tab.

Bob
Joomlimo 30 Oct, 2012
I'm facing the same issue here; the form doesn't appear at all except for the developers' link. When I switched on a debugger on the load event, I got two messages that read as follows:

Data Array:

Array
(
    [option] => com_chronoforms
    [chronoform] => user_contribution
    [Itemid] => 
)


Validation Errors:
Array
(
)


I also would like to inquire whether there's an option to mail the form values in plain/text format or whatever via the wizard, other than designating that explicitly in HTML code.

Cheers
GreyHead 30 Oct, 2012
Hi Joomlimo,

Please see this FAQ

There's an option in the Email action to send plain text emails.

Bob
Joomlimo 30 Oct, 2012
Thank you.

I used to use old versions of Chronoforms, but I think things have gotten a bit tougher, since then.

Good day
rjmcintyre7 16 Jan, 2013
I have had this same issue and it took me awhile to figure out the root cause, but here is what I finally found (regarding the form NOT showing...your data issue seems odd...haven't had many issues there):

In WIZARD EDIT:
-On the right, Under "DROP", select "EVENTS"
-On the left, Under "DRAG", select "Show html" and drag it to "OnLoad" on the right
-Click on the settings for the "Show html" that you just dragged (on the right).
-I have the settings as follows:
-Republish form data: yes
-Display field errors: yes
-Load Security Token: yes
-Load Keep Alive: no
-Curly brackets replacer: yes

It showed up after all of that...as a note to the Chronoform team, this "Show html" should be defaulted on like it used to be...I don't remember this being a selections...and this took some serious time to figure out...but, I still find this to be one of the most flexible form tools out there and stick by it!
GreyHead 17 Jan, 2013
Hi rjmcintyre7,

I agree that the Show HTML should probably be a default action. It is if you use the Easy Form Wizard (along with a bunch of other common actions). The solution is in this FAQ and multiple posts in the forums here. I'm sorry that you wasted your time.

The default settings for the Show HTML action are OK 99% of the time.

Bob
GreyHead 17 Jan, 2014
Hi charleyhankins,

Fixed, thank you, I'm afraid that Max broke all the old links when he upgraded the site to Joomla! 3 :-( However the FAQ search is much improved and you can usually find them from there.

Bob
This topic is locked and no more replies can be posted.