Forums

Error system messages translation

moto05 07 Sep, 2012
Hi,

i am trying to change these system messages:

You must provide your name.
You must provide your username.
You must provide your password.


I need to translate them in italian.

Can anybody help me?

Thanks,
Alex
Max_admin 08 Sep, 2012
Hi Alex,

Did you try to use a Multi language action, configure it for Italian and use:

You must provide your name=italian translation here
You must provide your username=italian translation here
You must provide your password=italian translation here


?

Regards,
Max
Max
ChronoForms developer...
Did you try ChronoMyAdmin for managing your Joomla database tables ?
moto05 11 Sep, 2012
Thank you for answer,

I've tried to do it without any result.

Can you explain me what exactly I have to do?

Thanks,
Alex
Max_admin 11 Sep, 2012
Hi Alex,

Drag a Multi language plugin to your "on load".

Set the language inside to italian "it-IT" I think.

Write:
You must provide your name=È necessario fornire il tuo nam


Save and test the form, does it work ?

I didn't test it and I'm not sure if it will work, as I have mentioned these messages may not be translatable.

Regards,
Max
Max
ChronoForms developer...
Did you try ChronoMyAdmin for managing your Joomla database tables ?
moto05 12 Sep, 2012
It doesn't work.

Do you know how can I modify the core of extension to change this text?

Thank you,
Alex
GreyHead 12 Sep, 2012
Hi Alex,

Where are these messages showing? Please post a link to the form so I can take a quick look.

They sound more like Joomla! system messages than ChronoForms messages. But the system messages should translate automatically.

Bob
GreyHead 13 Sep, 2012
Hi Alex,

I've checked and the Multi-Language plug-in doesn't work with these messages (I'm not clear why, it may have something to do with them being error messages and not in the main Form HTML).

There are two possible fixes that I can see for the moment:

The first is to add serverside validation to these inputs so that the errors are caught before this action. Either the Auto or the Custom ServerSide Validaton actions will work. The Auto one has more limited messages.

The second is to edit the administrator/components/com_chronoforms/form_action/joomla_registration/joomla_registration.php file

This message is at line 74
$form->validation_errors[$params->get($check)] = 'You must provide your '.$check.'.';
and there are a few others in the file as well.

Bob

PS The action really does need to have a language option for this :-(
This topic is locked and no more replies can be posted.