[WORKAROUND] WYSIWYG field not created in database

midulster 10 Feb, 2012

First time user so apologies if this is a stupid question. I have tried searching the forum.

Chronoforms 4.0 RC3.11
Joomla! 2.5.1

I've created a form and it works fine when I use a textarea. However if I drop the table and try to change the textarea to use wysiwyg editor option, then go back to create table the field doesn't appear on the list. If I switch off the wysiwyg option then the field name appears again.

Any help much appreciated.
GreyHead 10 Feb, 2012
Hi midulster,

I'm not clear what the problem is? You can create the table without the editor enabled; or you can add an extra column in the Create Table dialogue?

midulster 10 Feb, 2012
I can create the form perfectly, including database table creation and data storage, if I just use a plain textarea. But I want to use WYSIWYG editor. So I drop the table to start again, edit the form using Advanced Wizard, bring up the Element settings for the textarea field, tick the box to enable WYSIWYG editor and save the changes. Then back to the Forms Manager to Create Table but the field has now disappeared from the new table field list - drops from 16 fields to 15. (Screenshots attached).

I've repeated the process a few times now and the only thing I'm aware of changing is the tick box to enable WYSIWYG Editor.

midulster 11 Feb, 2012
I got round it by creating the form with a plain textarea, creating the data table and then editing the form to set the wysiwyg editor.
GreyHead 11 Feb, 2012
Hi midulster,

That one of the options I tried to suggest - sorry if it wasn't clear. You can also fool it by adding a commented out input in a Custom Element
<!-- <input name='xxx' type='text' />-->
That should be enough for the Create Table to find the name but won't affect the actual form.

midulster 14 Feb, 2012
Sorry I misunderstood your earlier reply. If I had been paying attention your advice was perfect. Thanks for you help.
This topic is locked and no more replies can be posted.