Can't Save Form Code when creating new ChronoForm

ozneilau 09 Jul, 2010
I have created dozens of Chronoforms on various websites but have suddenly come across a problem I can't solve.

I started with the form wizard but once there were more than about 50 fields, "Save" stopped working. It would throw me back to the Joomla Control Panel without saving the data. So I continued to code the form manually (copying and pasting the existing fields and updating the numbers and names).

When I pasted the form code and tried applying the change or saving the form, then the form would either revert to the version saved by the wizard or not save at all.

I tried creating a new form from scratch with the same result.

I tried reinstalling Chronoforms but again, the same result.

I set error reporting to maximum in Global Configuration and this error is displayed when trying to save the form:

Notice: Undefined index: html in /home/brucebro/public_html/administrator/components/com_chronocontact/admin.chronocontact.php  on line 689

I tried saving the form on a separate site (on different shared hosting) and it worked OK.

Could a setting on the host server be the problem? Versions are as follows:

Joomla 1.5.18
PHP 5.2.5
Chronoforms 3.1 RC5.5

I hope you can help.

I will private message you some login details in case you need them!

GreyHead 09 Jul, 2010
Hi ozneilau,

I had a quick test on your site. I managed to create an 80+ field form on the second attempt; the first attempt got the same message. I guess that passing the very large amount of data in the POST variables may be prone to corruption :-(

I'd suggest that you either (a) break the form into smaller chunks; or (b) include the Form HTML from an external file. I usually do this once the form HTML is more than 20 or so lines long.

ozneilau 10 Jul, 2010
Hi Bob,

Thanks for the prompt reply as usual!

By pasting the form HTML into the form code area and saving the Chronoform, I have tried creating the form on some other servers I look after, Interestingly, I only have the problem on the server where I am actually trying to create the form. The problem server uses PHP 5.2.5. The other seven servers I tested range from PHP version 5.2.6 to 5.2.13 and these all worked flawlessly.

I have logged a call with the web hosting company to see if they have any ideas.

Thanks for your help,

This topic is locked and no more replies can be posted.