How to use a ChronoForm to edit a record

neduz 06 Jul, 2009

After lots of try-and-error, and re-reading the available pdf's, I can view a table, add records to it with a ChronoForm, but now I'm stuck again and since I've got no hair left to pull out, I'm posting the question here:

Are you, and if yes, how are you supposed to change records using ChronoForms/Connectivity?
I've got a Connection, and set the "Record Edit Form:" in the Admin Settings tab to the form that works for inserting the entries. When I click "show data" on the connection, and click on a record, I get the form, with the values of the clicked record filled out in the form. But if I change a value, and click "Save", "Apply" or "Submit", nothing in the database changes. No errors are reported either. The form "action" parameter is "index2.php". The hidden field task has an empty value.

I attached the configuration of the form and the connection in the zip file.


GreyHead 11 Jul, 2009
Hi Tom,

Sorry to have been a while getting to this :-(

I can confirm that the Admin Edit doesn't work using your forms - nor, I suspect, any other forms.

Until Max takes a look at a this the workaround that I can suggest is to add {edit_record} to the body display and use the front end to edit or add data. If you give the frontend permissions to Admins only this shouldn't be any problem.

tamarteleco 29 Jun, 2010
Hi Bob,

I want to edit the record rows throw the ChronoConnectivity admin back-end until I finish the LDAP user recognision. I'm trying to do some updates in a row, but something isn't working properly.
When I click "Show data" the table with the columns and fields choosen before in the ChronoConnectivity Admin Settings appears:

This works fine,

But if I try to edit:

Not all the data appears and because that, the forms ask me for the mandatory fields (in red text).

So I can't change for example in the 'Status' columns from 'High' to 'Medium' one row...

May be the solution is to create a different form just for editing?

GreyHead 29 Jun, 2010
Hi tamarteleco,

The Google docs links aren't accessible to me. Please attach the docs/images to your post here.

tamarteleco 29 Jun, 2010
Hi Bob,

I've edited my last entry attaching the documents.

tamarteleco 01 Jul, 2010
Hi Bob,

Did you see the images attached?

tamarteleco 06 Jul, 2010
Hi Bob,

Do you know why not all fields are read when editing data in back-end?

GreyHead 07 Jul, 2010
Hi tamarteleco,

I don't know the answer to this. I don't try to edit the data in the Back end. Instead I create a ChronoForm with admin only access and use that in the front-end.

nancyh 24 Jul, 2011
I added a row for {edit_record} to the body and it doesn't show..permissions are set to admin and I'm logged in to the back end as superadmin...

Can someone point me to a tutorial on how to enable edits - from either the back end or front end?
This topic is locked and no more replies can be posted.