Forums

Unable to Submit Form

stephenoutram 15 Mar, 2009
Hi all,
Joomla 1.5
ChronoForm V3.1 RC2
IE7 and Opera 9
Site: http://www.conscioushorseconsciousrider.com

I created a template with validation, dropdowns and checkbox elements plust some text. When I test it and click Submit, nothing happens.
http://www.conscioushorseconsciousrider.com/index.php?option=com_chronocontact&chronoformname=Competition

So, I created a simple form with just 2 text boxes, no validation, which seems to works ok.
http://www.conscioushorseconsciousrider.com/index.php?option=com_chronocontact&chronoformname=Test

Another odd thing, that may be related is, I created the formsin the Wizard, but when I saved them it stripped out all but one of the menu choices in the dropdowns, and same with the checkboxes.

I tried a bunch of stuff like swapping templates and switching off some modules, but no joy.

I have no idea what to do next and would be very grateful for some assistance
Cheers
Stephen
GreyHead 15 Mar, 2009
Hi Stephen,

You have the JQuery JavaScript Library loading on the page which will conflict with the MooTools library that ChronoForms is using.

If you disable the JavaSCript features of ChronoForms and set up server-side validation the form should work OK.

Bob

PS MooTools is the JavaScript library that Joomla now uses and loads so you may find similar problems elsewhere on your site.
Max_admin 16 Mar, 2009

I created the formsin the Wizard, but when I saved them it stripped out all but one of the menu choices in the dropdowns, and same with the checkboxes



this is a bug which will get fixed in V3.1 RC3, few hours before its out!

Max
Max
ChronoForms developer...
Did you try ChronoMyAdmin for managing your Joomla database tables ?
stephenoutram 16 Mar, 2009

If you disable the JavaSCript features of ChronoForms and set up server-side validation the form should work OK. Bob



Thanks for all your replies,
JSQuery is the script the template uses (Mocha by JoomlaJunkie). There is an option in the template to turn off MooTools, which I did, but no difference in ChronoForm. And I swirched back to Joomla's Milky Way template but no change in the form.

I also removed all validation from the form and tried that but it stil would not submit. So, maybe its more than validation.

Bob, how do I disable ChronoForm's JavaScript features? Where would I do that?

THanks once again for your help,
Cheers
Stephen
stephenoutram 16 Mar, 2009
Getting closer,
I relaised there is a header module (a slide show) provided by JoomlaJunkie for this template, which probably uses JSQuery. So, when I switch all that off and change to Joomla's default template things seem to work much better.

I guess I have to look at the template I bought from JoomlaJunkie and see what else is possible there. Damn! I like that template. Oh well ... 🙂

Many thanks
Stephen
GreyHead 17 Mar, 2009
Hi Stephen,

ChronoForms uses quite a lot of JavaScript - for validation, for calendars, for tooltips, and for restoring field values. You can turn most of it off by setting 'Load ChronoForms Scripts' to No in the General Tab, turning Validation off in the Validation Tab and setting 'Try to Restore Fields' to 'No' in the Anti-Spam tab (also by not using calendars and tooltips).

All that said, ChronoForms uses the Joomla 'standard' MooTools 1.1 library and the code is pretty benign; you are likely to encounter increasing problems with other Joomla extensions if you have JQuery or Proptotype loading.

Bob
stephenoutram 17 Mar, 2009
Thanks Bob,
Got the message. Actually, I turned off the modules using JSQuery and changed the template and ChronoForm worked perfectly. I also tried two other form components and had similar problems wirh them. So the issue is clearly not with the from componnents.

Thanks for your assistance. I'm having a chat with the template developer to see if there is a solution from their end.

Cheers
Stephen
This topic is locked and no more replies can be posted.