Forums

Unicode characters in comment

dax 06 Mar, 2009
First of all let me congratulate you for this great piece of software. I actually tried couple of comment extensions but this one seem very slick and neat, just like wordpress comment feature so I liked it at first glance.
The installation was breeze and configuration didn't take long.
However, I got a strange problem. My site is in Gujarati and myself as well as visitors are going to post comment using unicode characters. I dont need a translation of comment, just posting of comment thing to show up as written by guests. I first tried the same at your demo page and it came out perfectly in Gujarati unicode characters. However when I tested the same thing on my site, all i see were ?????? question markes in comment and also in the backend. So I don't know where I'm wrong. I checked the configuration (parameters) page, but can't find anything that can fix it.
I'm sure I'm missing some silly thing. Can you pl. help. I will appreciate your response.
FYI, I have installed sh404sef.
Max_admin 06 Mar, 2009
Hi dax,

first check all your DB, DB tables, DB tables' fields and make sure their characters format is utf8_general_ci then check if there is something at your server config which may force non unicode format because another user had this one before!

Cheers
Max
Max
ChronoForms developer...
Did you try ChronoMyAdmin for managing your Joomla database tables ?
dax 06 Mar, 2009
Hi there,
Thanks for prompt reply.
I did check and i see following tables :
jos_chrono_comments, jos_chrono_comments_rate_log, jos_comment, jos_comment_captcha, jos_comment_setting, jos_comment_voting
are all having " latin1_swedish_ci " in collation field. I'm not very good at databases and i don't want to mess things up in experiment. Can you please guide me How do I change their language collation to "utf8_general_ci" using phpmyadmin ?
There are some other tables also that has "latin1_swedish_ci" but i guess that are for other plugins, modules etc.
Is there anything else that I need to do ?
Thanks in advance for your help.
dax 06 Mar, 2009
Hi,
I think I just figured out how to change the language collocation in sql tables. and after applying the settings as mentioned by you, I actually was able to write comments in unicode. So thanks a lot for your help/guidance. You made my day !
Now, was that the way the module is installed, or did i do something stupid when installing the module ? I mean, If i am going to use it on my other site, will i have to do the same thing again, or is there any option at the time of install that take care of it itself ? just a thought ...
Max_admin 08 Mar, 2009
Hi dax,

it depends on your server config I believe, I think joomla by default tries to make the database and tables as utf8 but some server setting controls this, I'm not sure which exactly!

Cheers,
Max
Max
ChronoForms developer...
Did you try ChronoMyAdmin for managing your Joomla database tables ?
This topic is locked and no more replies can be posted.