Forums

Resolved: Uploads gone awry

nfg 10 Jan, 2009
Hello,

Like so many people I'd like to thank for this fine component. Combined with Jumi I can do amazing things without a great deal of work. It's genius.

I am of course having a problem though. I'm posting an image upload and the images are not available. I'm running latest stable Chronforms with j1.5.8 under php 5.

I'm getting this in the error log:
[Sat Jan 10 .... ] doesn't appear to be a valid Zend extension, referer: http: ....i ndex.php?option=com_chronocontact&task=send&chronoformname= ...

The email is sent, the data written to the table and all is well, but no image. I installed the image resizer mentioned here
http://www.chronoengine.com/forums/index.php?option=com_chronoforums&cont=posts&f=4&t=12016

But I was having this problem both before and after the install of the plugin. (no I didn't expect the plugin to fix it) The image is simply not being written to the server.

Any suggestions?
Thanks.

nfg
GreyHead 10 Jan, 2009
Hi nfg,

I've no idea - are you running Zend Optimiser or the Zend Extension Manager?? The docs for the Extension Manager are here They do mention this error message and suggest a fix but it doesn't mean much to me.

Bob
Max_admin 10 Jan, 2009
Hi nfg, so this happens with "image" uploads only or with other files types too ? me too never faced this issue before so its a good idea to drop your hosting admin an email now!

Regards
Max
Max
ChronoForms developer...
Did you try ChronoMyAdmin for managing your Joomla database tables ?
nfg 13 Jan, 2009
Okay,

In answer to your questions:

Yes it appears that this server is running Zend extensions, but I'm not sure how normal that is to be honest, or how to tell from phpinfo() what exactly is going on with Zend.

The host in this case is MediaTemple's GridService which has some odd settings at the best of times. It is interesting to note that I have since realized that Chrono is not the only package showing this error, not by a long chalk. Yet everything on the site continues to work correctly, at least from the view of the browser.

J 1.5 with ftp turned off is able to upload images fine, AND it shows the error, so my guess is that this Zend Extension error is not the culprit, however disturbing it might be.

I've also put permissions out of the running since other directories are accepting uploads with the same owner and perms as the chronoforms upload directories. Besides I'd expect errors from PHP if that was the case.

I don't know if any of this sparks an idea. I'm still hoping vaguely that I've done something dumb.

Thanks for your responses in any case, now I'm going to look around in chrono to find out what it's doing in this area.

nfg
nfg 13 Jan, 2009
I did something dumb! Hurray!

Actually I had not read EVERY item on the FAQ related to uploading things. Most of these refer to fireboard, but the one at the end had the answer.

http://www.chronoengine.com/faqs.html

See number 29

Check that you have put enctype='multipart/form-data' in the Form tag attachment field on the General tab.



It can be gratifying to do dumb things.
This topic is locked and no more replies can be posted.