Forums

On table view, columns don't show when in column list, but they do "Include all the provider fields" is checked.

farscape 14 Jun, 2018
I have a simple connection set up as a learning exercise. Everything works except for one thing. I am using a table view, and I want to list the three specific columns to display, with headers defined, but only the headers appear. I've tried everything I can think of, but the only way I see all three columns is with the "include all provider fields" checked, but I can't seem to find a way to customize the column headers using that option. Thanks in advance!

Here is the read data function:



Here is the view (I have tried with "include form?" on and off. No difference in the results.



I see the data in the debugger:



However, the table view shows values in only the first column:



If I check the "include all the provider fields" option, all three columns of data appear, but I can't customize the headers (the data shown is as expected with my test table):

GreyHead 14 Jun, 2018
Hi farscape,

Have you tried adding the label at the end of the field list entry - see the note under the box :
"Write each field name or path in the data set and its label, example: Model.field_name:Label"

Bob
farscape 14 Jun, 2018
Hi Greyhead,

Yes. I show one attempt in the second screenshot above. That shows labels that are the same as the column names, but I've also tried labels that didn't match the column names. too. No difference.

Bill
GreyHead 15 Jun, 2018
Hi Bill,

I suggest that you ask Max for his input using the Contact link above and linking to this thread - my CCv6 knowledge is still pretty limited.

Bob
farscape 15 Jun, 2018
Will do. And I just realized that I posted this to the wrong forum. Sorry!
This topic is locked and no more replies can be posted.