Forums

Chronoforms for Wordpress and PHP 7.1

mmaack 28 Apr, 2017
Is this ever going to be updated? I've had to update my PHP to v7.1 and get deprecated code warnings. 3 years is a bit much.
GreyHead 29 Apr, 2017
Hi mmaack,

Deprecated messages should not be a problem unless you have PHP error reporting set too high. PHP 7.1 was only released last December and my host doesn't yet offer it :-(

What problems are you getting exactly?

Bob
mmaack 01 May, 2017
I did, in fact, have my PHP debug settings enabled due to other non-related issues I was having transferring sites to the new server. The message went away when the setting was turned off.

Thanks
mmaack 08 May, 2017
As a side note, my forms work, but I get an error if I have to modify and save a form.
GreyHead 08 May, 2017
Hi mmaack ,

What error do you get?

Bob
mmaack 08 May, 2017
Uncaught exception: Cannot use string offset as an array.

Getting this on my Joomla sites as well.
Max_admin 08 May, 2017
Hi,

A quick solution which works on some servers is to go to Chronoforms settings and disable the wizard "safe save" feature, and assuming that you have high "max_input_vars" setting on your server then all should be good hopefully.

Best regards,
Max
Max
ChronoForms developer...
Did you try ChronoMyAdmin for managing your Joomla database tables ?
GreyHead 09 May, 2017
HI mmaack,

That message is a known problem when using PHP 7.1 - ChronoForms is fine when running 7.0

Unfortunately the host for my test site is not yet offering 7.1 so I have no way to find the exact cause.

Bob
Max_admin 29 Jun, 2017
1 Likes
Hi conguyengia,

v5 not yet, but v6 yes, you can download v6 from the downloads section.

Best regards,
Max
Max
ChronoForms developer...
Did you try ChronoMyAdmin for managing your Joomla database tables ?
This topic is locked and no more replies can be posted.