TCPDF ERROR: Could not include font definition files: Helvetica

pieroso 04 Apr, 2016
Hi, with 3.4 joomla, virtuemart 3 and cf 4v had installed TCPDF action and worked well, but I switched to joomla 3.5.0 and now when I confirm an order cart I get the message: TCPDF ERROR: Could not include font definition files: Helvetica
I checked into the "fonts" folder and there is helvetica.php file.
What can I do?
Thank you.
GreyHead 04 Apr, 2016
Hi pieroso,

Does this work if you test the form from the View Form link in the Forms Manager? I'm wondering if the problem is with the path to the font file, or the file itself. I've checked and TCPDF is working OK for me using Helvetica in Joomla! 3.5 and CFv4

pieroso 05 Apr, 2016
Hi Bob,
I set the maximum error report and now I get this message:
Warning: opendir(/home/ueqjwzri/domains/ failed to open dir: No such file or directory in /home/ueqjwzri/domains/ on line 4154 TCPDF ERROR: Could not include font definition file: helvetica.
Please help me, I do not know what to do.
Thank you

GreyHead 05 Apr, 2016
Hi Piero,

That folder doesn't look right, in my CFv4 installation the TCPDF files are in /administrator/components/com_chronoforms/form_actions/tcpdf and as you can see there are a set of font files there. I'm not sure why you are seeing a different folder path there :-(

pieroso 08 Apr, 2016
Hello Bob, I see the same path that you showed me in your installation, I think that the problem was created by the installation of plugins that are not able to do regularly but, as you suggested you transferring the files via ftp. I contacted my web host who told me that he tried to regularly install the plug having the same error message, so I do not know what to do.
Thanks again.
GreyHead 09 Apr, 2016
Hi pieroso,

Please unzip the action file and use FTP to copy all of the contents into the /administrator/components/com_chronoforms/form_actions/ folder That should install the files in the correct location - check the result to make sure that it looks like the folder structure in my image.

pieroso 09 Apr, 2016
Hi, Bob I FINALLY found the problem: had remained the libraries folder of TCPDF component, even though I had uninstalled.
Thank you so much for your time.
This topic is locked and no more replies can be posted.