Buy Now
Sign in

ReCaptcha Is Not Showing/Working (CF v6)

LikeStuff , January 17 2020, 00:12
L
LikeStuff 314
January 17 2020, 00:12 #390750
This is so odd. I copy a working form to another site but for some reason the Captcha is not working. So I deleted the Captcha and then:

1) I add it back as per attached
1) I enabled the "Check security fields" setting
2) I then add my site and secret keys provided by Google

Why is it not working? Thanks
No_Captcha.png
healyhatman 9
January 17 2020, 01:18 #390751
Have a look in the console (F12)
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
L
LikeStuff 314
January 17 2020, 16:44 #390762
Okay.... I know you are trying to help and I really appreciate it but your responses are very vague. I'm asking a question because I have no clue and this is not helping much. Sorry
I don't know what console you are referring to, the browser? the component?
healyhatman 9
January 17 2020, 21:12 #390764
F12 opens the browser console, and the component doesn't have a console.
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
L
LikeStuff 314
January 17 2020, 21:22 #390765
What am I looking for in the console?
healyhatman 9
January 17 2020, 21:36 #390766
Any errors when you load your form.
Also nice to post your form debug from submit, and if that doesn't work turn off check security fields and use the manual check recaptcha action.
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
L
LikeStuff 314
January 18 2020, 17:54 #390780
No errors that I see. I just turn if off 'cause I can't get the captcha to show
Thanks for your help anyway.
healyhatman 9
January 18 2020, 23:47 #390786
Delete the action and put it in again. You mean it doesn't show up AT ALL?
If the form's simple enough try just rebuilding it.
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
L
LikeStuff 314
January 19 2020, 01:12 #390790
Yes, the captcha does not show up at all.
I had also created a new form but I got the same result - the captcha does not show up at all.
Thanks!
healyhatman 9
January 20 2020, 02:10 #390798
That's VERY strange. Reinstall CF maybe?
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
admin 28
January 26 2020, 09:28 #390916
If the reCaptcha is not showing at all on the form then it may be a faulty Google key or a problem on your web page, can you post a link to the page ?
Max
If your main question got answered then please mark the answer using the button!
Did you try the new ChronoForms7 ? if yes then please send us your comments!!
Z
zassie83 2
June 09 2020, 19:25 #393008
[div wfd-id="67"]I pretty much have this issue.
In fact: the CF has been working for years but stopped functioning a few weeks ago.
It doens't show the Captcha when the form is loaded in the website (when loaded stand alone it does show the captcha).
It does show up in the console, it should be there but it isn't. Cants seem to find any CSS that might be hiding it either....

It was working until a few weeks ago.... any ideas?
https://www.078ballon.nl/contact (one of the two forms I use, both have same issue)[/div]
admin 28
June 10 2020, 04:32 #393011
There is a JavaScript error on your page which I think is causing this, try to find a way to disable mootools on that page!
Max
If your main question got answered then please mark the answer using the button!
Did you try the new ChronoForms7 ? if yes then please send us your comments!!
Z
zassie83 2
June 10 2020, 12:43 #393032
[div wfd-id="67"]I've disabed mootools on that page (using a plugin)... captcha still does not show up. [/div]
GreyHead 64
June 10 2020, 13:11 #393034
Hi zassie83,
Your template is still loading MooTools and there is still a JavaScript error. I suggest that you check to see if RocketTheme have a more recent release without MooTools.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much