Buy Now
Sign in

Comment Submit Issues. Is it Caching? NOTAUTH response

cruiserdude , March 25 2009, 19:34
cruiserdude 3
March 25 2009, 19:34 #27694

I've recently bought a chronocomments licence and mostly it's a pretty awesome product, I am however having an issue with comments not getting submit reliably. The normal order of events is 1) somebody complains they can't comment 2) I go try comment it works fine 3) I think they are just doing something noobish. Thing is when, in annoyance, I went to submit a comment it failed for me in IE, then worked in FF then failed in FF.

So I chucked Charles up to have a look at the request and the difference between IE and FF on the request side was nothing but on the response I was getting from IE was NOTAUTH.

Hmm, quick search and we have the following lines:
    echo 'NOTAUTH';

Is that form token being posted supposed to be unique per request? I would think so, in my case it wasn't between IE and FF, they were identical which makes me think it might be a caching issue. If it is caching is there a way to turn caching off for chronocomments and if not do you folks have a work around for this issue. I searched the forums and found only a reference to chronocomments.php not including the JToken code but it definitely has that.

The thing is I've commented out the above line so it works for the moment but I'm not sure if that opens me up for some abuse. As it is your comment component gets more spam then I've ever seen.

Let me know
admin 32
March 25 2009, 23:09 #27749
Hi Simon,

I promise to investigate the issue soon, for now I have no ideas for this, sometimes the checktoken method makes problems with few users of Chronoforms too!

cruiserdude 3
March 26 2009, 16:58 #27816
Thanks Max,

I do a bit of recreational joomla programming so I'll let you know if I find anything along the way. Are there any side effects of removing the token check that I might want to know about?

admin 32
March 26 2009, 20:10 #27840
Hi Simon,

that would be great, no side effects except if somebody tried to access the post url directly, but i think it checks to see if at least some comment was posted!

isobrown 1
April 27 2009, 05:33 #30899
Don't know if this will help you but I experienced a NOAUTH problem today
seems like activation of joomla cache generates this kind of bug.
I disabled cache and now chronocomment works fine again.
cruiserdude 3
April 28 2009, 05:16 #30995
Thanks for the info. Turning off caching isn't really an option for me as it significantly speeds up the site. Max is there a way to stop the caching applying to comments?
higgalls 9
June 11 2009, 03:50 #34380
Someone told me they were having a problem today with posting comments. They spent ages typing it, and then clicked on SUBMIT, and it came up saying that it is submitted and will be put online when reviewed. However, it didn't come up in the admin.
They then typed it again (this time typing it in Word first, and then pasting it into the comments form) and again the same problem happened.
The form was still filled out so I reclicked on SUBMIT, but it doesn't do anything.

Then I reloaded the page, and pasted it in again, and this time it worked.

This is all in Internet Explorer (well its the only reported problem with it so far).

Is this the same problem? Any idea on how to fix it/make it more reliable? I have no idea whether people are submitting more comments and not working.

oettam 1
July 27 2009, 19:48 #37944
I 'm experiencing exactly the same issue.
It is embarrassing, becuase guests leave the web site and for sure they will not come back, becuase their comment are not published (the fact is that me, as admin, I'm not notified neither the comment is present on Comment manager)

Admins, it would be appreciate your help.

Tks in advance
mat 32
September 14 2009, 15:28 #40316
Same issue here :?
With global cache disabled it works, but I can’t use the site with cache disabled.
The strange – and what make me light on only now – is that if I’m logged in as administrator and I try to comment from Safari and the global cache is enabled, I can leave the comment.
On ChronoEngine site, is the global cache enabled?
mr.morton 3
March 31 2010, 14:01 #49473
I'm having this problem too - did it ever get solved?
February 19 2011, 11:29 #64980
justingilbert 2
November 04 2011, 14:33 #110853
Yes i got it solved