Buy Now
Sign in

Does not display correct time...

eendii , November 11 2008, 12:59
E
eendii 5
November 11 2008, 12:59 #16857
My Joomla server is set to timezone UTC + 7.

For every comments inserted/saved in articles, when displayed from "Comments Manager", column "DateTime" display the correct time comment was saved. But if viewed from articles, the time displayed with the comment is not correct, it is the saved time + 7 hours.

How do I fix this??

Please help.
K
kelebekce 5
November 11 2008, 18:13 #16880
anyone help this problem admin component (Chrono Comments - Comments Manager) time it is true but site Comments time UTC +2
admin 33
November 11 2008, 21:47 #16896
Hi kelebekce,

in the global config of Joomla, did you set the correct time zone ? ChronoCommenst will use the Joomla time!

Regards
Max
E
eendii 5
November 12 2008, 00:37 #16929
Global config of Joomla timezone is set to correct timezone (mine is UTC + 7)
Time displayed is already correct for joomla and joomla administrator... including chronocomments if viewed from "Comments Manager".

But when comments are displyed in articles, the comment time is added with 7.
I think maybe the load comment function treat the time as UTC and added another 7 to it.

How do I fix this?
K
kelebekce 5
November 12 2008, 11:00 #16942
22.jpg11.jpg33.JPG
comment time it's true when i set UTC +0 but my site time UTC +2
Attachments
22.jpg
22.jpg
(31.73 KiB)
5608 Downloads/Views
33.JPG
33.JPG
(9.4 KiB)
5616 Downloads/Views
11.jpg
11.jpg
(12.07 KiB)
5609 Downloads/Views
admin 33
November 12 2008, 11:43 #16950
Hi,

at components/com_chronocomments/chronocomments.php

find:
JHTML::_('date', $commentx->datetime, JText::_( 'DATETIMEFORMAT' ))


replace with :
JHTML::_('date', $commentx->datetime, JText::_( 'DATETIMEFORMAT' ), 0)


let me know!

Regards
Max
E
eendii 5
November 12 2008, 14:22 #16968
Still the same. Doesn't seem to change anything...

Does that work on yours, kelebekce?
K
kelebekce 5
November 12 2008, 14:55 #16971
Thanks Max

old comment time not true but new comment time is true.

Eendii write new comment
K
kelebekce 5
November 12 2008, 16:26 #16976
Solve the problem eendii

1-(components/com_chronocomments/chronocomments.php) line 290-665-723 (3 times)
find:
JHTML::_('date', $commentx->datetime, JText::_( 'DATETIMEFORMAT' ))

replace with:
JHTML::_('date', $commentx->datetime, JText::_( 'DATETIMEFORMAT' ), 0)


2-(plugins/content/ChronoComments.php) line 217-275 (2 times)
find:
JHTML::_('date', $commentx->datetime, JText::_( 'DATETIMEFORMAT' ))

replace with:
JHTML::_('date', $commentx->datetime, JText::_( 'DATETIMEFORMAT' ), 0)


change 5 times and it's work
admin 33
November 12 2008, 22:05 #17002
Good!!
W
warriorgov79 34
November 13 2008, 01:01 #17023
Hi everyone,

This fix sets my time in the component and Latest Comments module to Eastern Standard. My UTC in backend is -10. My workaround for the component is to change the "0" to "-5". However, I'm afraid I'll have to change it again manually to accomodate Daylight Savings Time as my time zone does not change with the seasons. Any suggestions?

Joomla 1.5.8
Firefox 3.0.3
Firebug 1.1.0b12
Web Developer 1.1.6

Aloha,
warriorgov79
admin 33
November 13 2008, 15:19 #17039
Hi warriorgov79,

Why should you add -5 if your time is -10, how are your dates looking at both admin and frontend without this change ?

Regards
Max
W
warriorgov79 34
November 13 2008, 21:25 #17067
Without the mods, my time in the backend is 5 hours ahead; frontend is 5 hours behind.
admin 33
November 13 2008, 23:01 #17071
Hi Hi warriorgov79,

at the next version I will add a fix for this issue and you can easily upgrade!

Regards
Max
W
warriorgov79 34
November 13 2008, 23:40 #17076
Mahalo (thanks) Max! ChronoComments is simply the best! I appreciate all that you're doing to help us noobs. I'll wait for your next release to install on my beta site. In the meantime, I'll keep playing with the current version in my sandbox. Aloha! warriorgov79 out...
E
eendii 5
November 14 2008, 08:46 #17093
Hooray...

Thanks kelebekce.... Thanks Max...!!
It works now.
admin 33
November 14 2008, 13:20 #17109
Thanks all!
C
ColinF 3
January 15 2009, 09:16 #21262
Hi I just installed ChronoComments and got it up and running. I noticed my time was off by 1 hour, so I tried this fix thinking it was the same issue. I replaced the code in the 5 locations listed in the previous post. Unfortunately, this did not fix anything. I tried making new comments and they are still off by 1 hour. I double checked the server time zone in the global settings and it is set correctly. Any ideas?
admin 33
January 15 2009, 20:39 #21290
Hi Colin,

Do you have daylight saving now ? may be change the 0 in the fixes to 1 or -1 and see ?

Regards
Max
C
ColinF 3
January 23 2009, 10:02 #21816
Thanks. That did it.