Enable editor buttons doesn't work

Petkova 18 Feb, 2012
Hello, dear ChronoEngine team,

I have to admit your component is fantastic, it's the core of my site.
However I was very sad when i found out that i cannot enable editor buttons for my text areas. Here is the option I thought i might use: Text area edit > Editors (tab)> Show editor buttons.
I thougt this should show Read more, Add Article, Image and Page break buttons, isn't that so? For some reason it's not showing them, I saved hundred times, I'm not using cache, I'm using JCE editor, but with TinyMCE it's not working as well. Is this behavoiur normal?

Thanks in advance,
Kristina Petkova
GreyHead 18 Feb, 2012
Hi Kristina,

Which version of ChronoForms are you using? You can find the version from Site Admin | Extensions | Install/Uninstall | Components in Joomla! 1.5 or Site Admin | Extensions | Extension Manager | Manage in Joomla! 1.6/1.7/2.5.

I don't know anything about editor buttons but can take a look.

Petkova 19 Feb, 2012
Hello, dear Bob,

I'm using V4 RC3 for component, module and plugin. You can check it very easy, create a form with a text area, click on settings, go to Editors tab and check Show editor buttons to see if something happens. Strange thing is that it's checked by default, but nothing shows and it's the same if it's unchecked. Anyway, I was just wondering, thanks for replying.

Have a nice day,
GreyHead 19 Feb, 2012
Hi Kristina,

I dug in the code and it looks as though ChronoForms is sending the correct parameter to Joomla!
$editor =& JFactory::getEditor(); 
echo $editor->display('input_textarea_0', '', 400, 200, 12, 45, 1); 
The last paramter being set to 1 = true should enable the buttons.

I'm afraid that I don't know why that isn't working here.

This topic is locked and no more replies can be posted.