File upload doesn't work because /tmp is not writable

ad63810 16 Jun, 2009

I installed chronoform on a web hosted site (siteground), but I found that
the file uploadind doesn't work. After debugging, I think I found the problem :

--> the file uploading uses a temporary directory "/tmp", this directory is
hard coded somewhere, and "/tmp" is not writable on siteground websites !!!

Do you know where can I change this setting ?

by the way : when do you expect to deliver a multi-language version of chrono form ?


nml375 16 Jun, 2009
Hi Alain,
The temporary upload path is usually set in the php.ini server configfile, and is known as 'upload_tmp_dir'. It can usually only be altered by the system admin. Since the upload handling in Php precedes any php-scripts (including Joomla and CF), there is no way for CF to work around this. If you are permitted to run CGI applications on your host, you could write a separate file upload handler, but other than that your best option would be to get in contact with your admins.

This topic is locked and no more replies can be posted.