Buy Now
Sign in

Embedded FOrm

scion371 , March 10 2014
S
scion371
Have embedded a form into an article, which works fine and embedded a similar form in another page in a similar fashion but that does not send. Have looked at many entries in the forum and tried numerous things such as shown in "How do I show a form in an article?" None of the suggestions make any difference.

The for that works is: http://www.telemaruk.com/home/maintenance-&-repairs/vdr-radio-surveys.html

The form that does not work is: http://www.telemaruk.com/vdr-regulation-changes/ship-safety-&-security/vdr-regulation-changes.html

Can anyone shed a little light on this?
calculus00
Hello scion371,
I'm not a Chrono professional, but after checking your new post, I think that the following links may help:
How to post information from a Chronoform to ZoHo
What are the 'Easy Form' and 'Form' Wizards?
How can I add a mask to format a form input?
P.S: I'm just an automated service
I'm an automated service, my answers may help, but they may not be accurate.
S
scion371
Neither of the two forms mentioned now work. When completed via the Frontend view they send perfectly. When embedded into an article they do not send.

The code used is: <td colspan="3" valign="top">{chronoforms}sales-service-uk{/chronoforms}</td>

Have tried <div>{chronoforms}sales-service-uk{/chronoforms}</div>

Each form has a redirect event to a Joomla page and have tried it with a Show Thank You Event. Neither work.

Anyone with any relevant ideas?
GreyHead
Hi scion371,

The first link shows a Thank You message but no form or article. The second link shows an article with an embedded form - everything looks OK to me using Chrome.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
S
scion371
Sorry. I gave you the wroth URLs. They should have been:

This Works - Sends Email: http://www.telemaruk.com/vdr-regulation-changes/ship-safety-&-security/vdr-regulation-changes.html
This does not work - Does not send the email: http://www.telemaruk.com/home/maintenance-&-repairs/vdr-radio-surveys-2.html

Have gone through a whole rang elf options but cannot see the fault. Can you help?
GreyHead
Hi scion371,

The form looks OK in the front end. Have you tried setting the Relative URL to No (see this FAQ )?

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
S
scion371
Sorry to say I have ben through all of that and more without success. Have found other forms on the site that are not working. Again, on the face of it, they look fine and nothing out of place but they do not send on submit. e.g. Contact on the index page using a Rokbox popup. Look like I shall have simplify the Call to Action. Many thanks.
admin
Please test the form using the "frontend view" link in the forms manager or the test form link in the wizard, does it send the email in that case ?

Regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
S
scion371
Thanks for the response. I have tried this and the forms on both pages, which have a chronform embedded:
http://www.telemaruk.com/vdr-regulation-changes/ship-safety-&-security/vdr-regulation-changes.html ...and
http://www.telemaruk.com/home/maintenance-&-repairs/vdr-radio-surveys.html

They both worked in the Forntend View - no problem. Embedded into the page they failed to send. However, refreshing the page takes it through to the tank you stage, but does knit send.

It occurred to me that there was obviously something to do with the System rather than page code or Chronoforms. I turned the System Cache off and Voila they both send no problem. Ruins our attempts to optimise the site and leaves the question why do some forms work and others do not with the cache on.

Any additional thoughts on that would be gratefully received.

Many thanks.

Peter - Scion
admin
Hi Peter,

Joomla caches the whole article page, including the form, which breaks the form processing, the solution is to either disable the cache OR to set the "Relative url" setting to "no" under the "HTML" action settings.

Regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
S
scion371
Hi Max,

Many thanks once again for your help. I am sorry to ask but where am I looking for the HTML Action? I can only see, in the form's events "show html" On Load an there are several Yes/No drop downs, labelled Republish form Data (Yes); Display Fields Errors (Yes); Load Security Token (Yes); etc, etc but no HTML Action. Cannot see any other likely slot for this. Please advise.

Thanks,
Peter
admin
Oh sorry, that was for V5, in v4 you can find the same setting by clicking the form's name under the forms manager, you can find there the "Relative url" setting, just set it to no!

Regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
S
scion371
Hi Max,

That's great. Thank you very much - problem solved.

Regards,

Peter