Buy Now
Sign in

Errors!

The King , November 29 2007, 20:46
T
The King 15
November 29 2007, 20:46 #4147
Hi
I ve two forms on a site.
I have this errors (after submit is pressed):

Warning: reset() [function.reset]: Passed variable is not an array or object in D:\Inetpublic\xxxx\www\includes\joomla.php on line 3894

Warning: Variable passed to each() is not an array or object in D:\Inetpublic\xxxx\www\includes\joomla.php on line 3896
GreyHead 64
November 29 2007, 21:50 #4148
Hi The King,

This looks like a problem with the mailer not receiving the information in the form it expects. It's most likely that you are sending a field name where an e-mail address is expected or vice versa.

Please will you take a backup of your form and post it here, or email it to info at greyhead.net so that I can take a look.

You can also download the sample form from the downloads area here, Restore that into ChronoForms and see if it generates the same errors.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
T
The King 15
December 01 2007, 19:48 #4202
Hi Bob

I deleted the forms and made new forms.
I don't have any error now, but I don't recive form mails

I'll mail you the backups right now!
I hope it will work

Thanks!
GreyHead 64
December 01 2007, 20:42 #4203
Hi Alex,

Thanks for the forms, I spotted a couple of things that might cause problems.

1) You don't have Reply To names & email addresses in the forms. These are required and the Joomla mailer will not send emails unless they are there. In many cases now they also have to be valid for your smtp mailserver.

2) In the Special Fields tab you nave 'mail' in the CC Field but there is no field named 'mail' in the forms. I don't think this is a problem at the moment but it's easily overlooked and might trip something up in the future.

Bob
Attachments
curl_gh.php.txt
(4.05 KiB)
143 Downloads/Views
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
T
The King 15
December 04 2007, 00:19 #4242
Yes it works!
Thanks :side:


I replaced 'mail' in the special fields with 'email' but it doesn't work. I'm the only one to recive the mail.
I also want the one who subscribes to recive a BCC :pinch:<br><br>Post edited by: The King, at: 2007/12/03 19:31
GreyHead 64
December 04 2007, 01:46 #4243
Hi Alex,

If you want to CC the user then put email in the Special Fields | Email box. But anyhow, ChronoForms will send to both addresses if you use both boxes.

Are you checking with two different addresses? It's possible that the Joomla mailer filters out duplicate email addresses from the To list.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
T
The King 15
December 04 2007, 01:54 #4244
Hi Bob

Yes I want the user (who registers) to have a copy of the mail (BCC).
So I used Email in the specialfield BCC.
It worked very well before I had the errors
It worked damn :blink:
GreyHead 64
December 04 2007, 02:22 #4247
Hi Alex,

I just tested on your form and it looks as though it's working OK here. Feel free to send me a backup of the latest version.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
T
The King 15
December 04 2007, 03:20 #4251
Done (mail)
GreyHead 64
December 04 2007, 04:15 #4254
Hi Alex,

I had a look at the first form 'NB' and it looks fine, I wonder if the email is getting dumped somewhere because the from and to addresses are the same? Some mailservers try to be clever like this. Please try using a different email address in the To field.

Bob<br><br>Post edited by: GreyHead, at: 2007/12/03 23:18
Attachments
forms.zip
(5.58 KiB)
146 Downloads/Views
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
T
The King 15
December 04 2007, 17:17 #4271
Hi Bob

I don't know wwhat happens but it works now :ohmy:
I didn't change anything.

Thanks a lot!