Buy Now
Sign in

Publishing forms with other Joomla modules

nicholashg , March 31 2011, 13:16
N
nicholashg 62
March 31 2011, 13:16 #66901
Thanks to all for J1.6 component - everything running smoothly.

As forms are not yet available as menu objects in J1.6, it seems that forms need to be accessed from links within Joomla articles. This is not a particular problem but it creates a layout difficulty.

In my 3-column template, forms appear in the main content area as I would have expected.

I'm trying to publish modules in both left and right columns along with the form, partly to reduce the overall width of the form without fiddling any more with the css. The module in the right column is published 'On all pages' and appears alongside the form. The module on the left is published 'On all pages except those selected' and does not appear alongside the form, even though it's set to publish in the page from which the form is linked.

Is there a workaround?

Nick
admin 28
March 31 2011, 15:28 #66914
Hi Nick,

I can create a new menu item of type "Chronoforms" fine here on my J1.6.1 installation, so creating menu items should work fine, I click the "select" button in the "Menu Manager: New Menu Item" page and the light box shows all possible options including "Chronoforms"

Please show me a screenshot of yours if it doesn't work.

Regards,
Max
Max
If your main question got answered then please mark the answer using the button!
Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
N
nicholashg 62
March 31 2011, 15:42 #66916
Hi Max,
As you can see, the Chronoforms option isn't there on my installation (worked fine on J1.5).
Nick
Attachments
menu_select.png
menu_select.png
(18.83 KiB)
4121 Downloads/Views
admin 28
March 31 2011, 16:05 #66920
Hi Nick,

I see, I forgot to fix this issue in the installer XML file, please extract the installer ZIP package and upload the "views" folder to this path:
/components/com_chronoforms/

that should fix it!

Regards,
Max
Max
If your main question got answered then please mark the answer using the button!
Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
N
nicholashg 62
March 31 2011, 16:23 #66923
Great, thank you Max (I wish everything was so simple).
Nick
4
4est 5
April 07 2011, 21:03 #67523
Hello everyone

Max, it didn't fix it completely for me:

After copying the missing folder I can add forms in the menu, but they don't work.
After filling submitting the form, I keep getting the same page, with no errors. And no action is taken (send mail)

However if I access the forms as external links, everything works ok

Thanks

Dan
D
DamirK 3
April 07 2011, 22:24 #67526
Same here... I aded "views", worked for the menu, but now after clicking on SUBMIT, no action...
GreyHead 64
April 08 2011, 08:43 #67536
Hi,

The menus seem to be working for me. At least I see the debug data and thank you page and an email is sent.

You need the form name in the Basic Options | Form Name box and leave the Event box empty (or add load) unless you want to directly access another Event*.

Bob

* You might do this if you just wanted to execute actions - build a backup file, send an email, etc. - without needing any user data.
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
4
4est 5
April 08 2011, 08:57 #67540
I have the form name, otherwise it wouldn't show
No action

But as I said, submitting the form just reloads the page (with user data in place), with no errors
GreyHead 64
April 08 2011, 10:46 #67549
Hi Dan,

Please take a Form Backup using the icon in the Forms Manager and post it here (as a zipped file) or PM or email it to me and I'll take a closer look.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
N
nicholashg 62
April 08 2011, 13:38 #67569
Just to say I am experiencing exactly the same issue - forms fine when loaded from the 'Frontend view' link but no OnSubmit functions when loaded from a menu item (Chronoforms Display Form).
Nick
C
cmateron 7
April 08 2011, 19:12 #67599
hi

I just try to use the load event in the Menu side of the form and it does not work. The form reloads with the information but is not sending.

If I use submit then the form works but shows a message on the top and bottom of the form




How can this be corrected?

Thanks
C
4
4est 5
April 08 2011, 19:54 #67607
Here is my form, but I doubt it's something wrong with it, as it works in "frontend view"



here, I've posted it onlnine for the weekend, you can see it not working

http://navo.ro/index.php/test
But if you use the upper menu "formular garantii..." where is accessed as fronend view link, it works

Thanks
Attachments
CFV4_FormsBackup_08_Apr_2011_22_52_29.zip
(6.99 KiB)
564 Downloads/Views
R
rapcal 6
April 09 2011, 05:08 #67622
Same problem here. Form works from the "frontend view" backend link, but not when loaded from menu item.

I have no idea if this helps, but I've noticed that the backend link points to "index.php?option=com_chronoforms&chronoform=whatever_the_name_of_the_form", while "index.php?option=com_chronoforms&view=form".

Can't it be that this "view" part of the link is what is being malformed?
GreyHead 64
April 09 2011, 05:45 #67626
Hi 4est,

Thanks, I restored your form and it works perfectly both from the front-end link and from a menu item. I still have no idea what causes this problem :-(

Bob
Attachments
09-04-2011 07-44-07.png
09-04-2011 07-44-07.png
(35.96 KiB)
3212 Downloads/Views
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
GreyHead 64
April 09 2011, 05:48 #67627
Hi cmateron,

The image links you posted give me 404 Not Found errors.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
N
nicholashg 62
April 09 2011, 14:17 #67649
Does 'Restore Forms' fix this problem then?
What does 'Restore Forms' actually do? I'm reluctant to hit such a grand sounding option for fear of losing something and in the absence of any help information …
Nick
GreyHead 64
April 09 2011, 14:23 #67652
Hi Nick,

Save Forms saves a copy of the selected forms (or all the forms if none is checked); Restore Forms does the reverse, creates a new from from a saved one. It does nothing to your existing forms.

Here it's just a way for me to look at the form and form settings without needing admin access.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
N
nicholashg 62
April 09 2011, 16:34 #67665
Thanks, that all works perfectly.

I'm still struggling to understand why forms don't submit when accessed via a menu item. I've noticed a difference in the form action tags when the same form is accessed in different ways:

When accessed from 'Frontend view', the tag reads
form action="http://www.pitchcentral.com/index.php option=com_chronoforms&chronoform=psplaywright&event=submit"


When accessed via menu item Chronoforms Display Form, the tag reads
form action="http://www.pitchcentral.com/membership-forms/ps-playwright?event=submit&Itemid=526"


Could this have any bearing on why the menu item form doesn't work?