Buy Now
Sign in

Comment Submit Issues. Is it Caching? NOTAUTH response

cruiserdude , March 25 2009
c
cruiserdude

Hi

I've recently bought a chronocomments licence and mostly it's a pretty awesome product, I am however having an issue with comments not getting submit reliably. The normal order of events is 1) somebody complains they can't comment 2) I go try comment it works fine 3) I think they are just doing something noobish. Thing is when, in annoyance, I went to submit a comment it failed for me in IE, then worked in FF then failed in FF.

So I chucked Charles up to have a look at the request and the difference between IE and FF on the request side was nothing but on the response I was getting from IE was NOTAUTH.

Hmm, quick search and we have the following lines:

				   if(!JRequest::checkToken()){
      echo 'NOTAUTH';
      $mainframe->close();
   }


Is that form token being posted supposed to be unique per request? I would think so, in my case it wasn't between IE and FF, they were identical which makes me think it might be a caching issue. If it is caching is there a way to turn caching off for chronocomments and if not do you folks have a work around for this issue. I searched the forums and found only a reference to chronocomments.php not including the JToken code but it definitely has that.

The thing is I've commented out the above line so it works for the moment but I'm not sure if that opens me up for some abuse. As it is your comment component gets more spam then I've ever seen.

Let me know
Simon

admin

Hi Simon,

I promise to investigate the issue soon, for now I have no ideas for this, sometimes the checktoken method makes problems with few users of Chronoforms too!

Regards
Max

Max
If your main question got answered then please mark the answer using the button!

c
cruiserdude

Thanks Max,

I do a bit of recreational joomla programming so I'll let you know if I find anything along the way. Are there any side effects of removing the token check that I might want to know about?

Thanks
Simon

admin

Hi Simon,

that would be great, no side effects except if somebody tried to access the post url directly, but i think it checks to see if at least some comment was posted!

Regards
Max

Max
If your main question got answered then please mark the answer using the button!

i
isobrown

Don't know if this will help you but I experienced a NOAUTH problem today
seems like activation of joomla cache generates this kind of bug.
I disabled cache and now chronocomment works fine again.

c
cruiserdude

Thanks for the info. Turning off caching isn't really an option for me as it significantly speeds up the site. Max is there a way to stop the caching applying to comments?

h
higgalls

Someone told me they were having a problem today with posting comments. They spent ages typing it, and then clicked on SUBMIT, and it came up saying that it is submitted and will be put online when reviewed. However, it didn't come up in the admin.
They then typed it again (this time typing it in Word first, and then pasting it into the comments form) and again the same problem happened.
The form was still filled out so I reclicked on SUBMIT, but it doesn't do anything.

Then I reloaded the page, and pasted it in again, and this time it worked.

This is all in Internet Explorer (well its the only reported problem with it so far).

Is this the same problem? Any idea on how to fix it/make it more reliable? I have no idea whether people are submitting more comments and not working.

Thanks.

o
oettam

Hi
I 'm experiencing exactly the same issue.
It is embarrassing, becuase guests leave the web site and for sure they will not come back, becuase their comment are not published (the fact is that me, as admin, I'm not notified neither the comment is present on Comment manager)

Admins, it would be appreciate your help.

Tks in advance

m
mat

Same issue here :?
With global cache disabled it works, but I can’t use the site with cache disabled.
The strange – and what make me light on only now – is that if I’m logged in as administrator and I try to comment from Safari and the global cache is enabled, I can leave the comment.
On ChronoEngine site, is the global cache enabled?

m
mr.morton

I'm having this problem too - did it ever get solved?

?
Guest

great

j
justingilbert

Yes i got it solved