Buy Now
Sign in

​Bug for Images

Proximate , February 07 2020, 14:33
P
Proximate 132
February 07 2020, 14:33 #391089
Hi at all!
If ChronoForums is operated on an https page, pictures are nevertheless integrated via http://. This leads to mixed content & an error in chrome / blocking of the image. Can this be avoided somehow?
admin 28
February 13 2020, 01:26 #391170
 1
I will check how to force https for images, but you can force all your site links to be in https using a .htaccess rule
Max
If your main question got answered then please mark the answer using the button!
Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
healyhatman 8
February 13 2020, 04:21 #391171
There's also a setting in Joomla to tell everything to use HTTPS not sure if that would work for that as well. If not .htaccess all the way
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
P
Proximate 132
February 14 2020, 10:33 #391179
Hi Max & healyhatman
I've tried now multiple options.
I have enabled "Enforce https" option on my hosting panel --> no changing
I have added the following rules to .htaccess (joomla root dir)

# Rewrite for force https for images
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
I have enabled the Force https option in Joomla!
nothing changed....
One thing i've noticed:
Even if logged in users and guests has the same "bug" that the images are not loaded via https if you are logged in the images are visible...
any more suggestions regarding this issue?