Buy Now
Sign in

0 - DOMXPath::query(): Invalid expression in selector >> body

pklinke , October 15 2019, 16:16
P
pklinke 34
October 15 2019, 16:16 #389577
Hi there,
on my site I have a problem with one form after changing to PHP 7.3:
0 - DOMXPath::query(): Invalid expression in selector >> body << in /home/www/psk-webdesign.de/libraries/cegcore2/vendors/emogrifier/Emogrifier.php on line 371
Going back to PHP 7.2 the error is gone. Another form on the same site works with PHP 7.3, too.
Regards
GreyHead 64
October 16 2019, 08:11 #389586
Hi pklinke,
Do you have the latest release of CFv6 installed? I thought that Max had updated the Emogrifier library to fix this (or something very similar).
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
P
pklinke 34
October 16 2019, 09:04 #389589
Because of there was no update visible in joomla, I have downloaded V 6.14 from your site.
Unfortunately there is no change. The error still exists.
Peter
healyhatman 8
October 16 2019, 10:58 #389592
Once you remember the exact fix for this Bob can you put it in a FAQ because this issue pops up ALL THE TIME and I can never remember the fix.
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
M
Minnie Mouse 111
October 28 2019, 22:31 #389776
I am having this issue too and i am running 6.1.4 running php 7.3.9
GreyHead 64
October 29 2019, 09:31 #389782
Hi,
In another thread Max posted this:
Please try to switch off the "Apply advanced template parsing and styles" setting in the email settings of your form
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
P
pklinke 34
November 19 2019, 18:01 #390052
Hi,
then it works. Should this be the solution for PHP 7.3 and future versions?
Peter