Buy Now
Sign in

Submit Button Not Working

Benevelli , October 09 2019, 16:16
Benevelli 4
October 09 2019, 16:16 #389481
Hi Everybody.
Once I'm clicking on send button nothing happens and I'm not getting any email.
I have the form did with same software working fine, I've compared setting and everything seems the same.
Not working form ->
Working form ->
Thanks for your help
GreyHead 64
October 10 2019, 08:36 #389484
Hi Benevelli,
The form looks OK at the front-end. Please turn on the form Debugger (on the Setup tab I think) temporarily and copy and paste the Debugger output here.
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
Benevelli 4
October 10 2019, 08:39 #389485
Of course, it works well now.

You need to know that I've redone the form from zero ...

The previous one, which didn't work, had been cloned from a previous form.

There must be a bug (unfortunately not just one) in Chronoform ...
LikeStuff 308
November 02 2019, 15:44 #389836
I'm having the same issue.  Below is the debug output.

[format] => html
[Itemid] => 113
[option] => com_chronoforms6
[view] => form

[validate_fields5] => Array
[log] => Automatic validation enabled.
[var] => 1

LikeStuff 308
November 05 2019, 22:38 #389891
Any suggestions why the form is not submitting? When I click on the button nothing happens.
LikeStuff 308
November 07 2019, 15:09 #389916
I had to redo the form as well in order for it to work. Strange!!
casperrutten 3
January 11 2020, 10:37 #390669
Hi, I have the same problem. I'm still in the 10 days demo, but if there is no solid solution to this problem, I have to leave Chronoform6.
I have the same debug output as LikeStuff, just the two arrays.
admin 28
January 14 2020, 09:00 #390713
Please test the form using the "preview" button in the form editor, does it work ?
what is the problem you are having exactly ? the debug above means that there is no email action or something is disabled, please attach a backup file of your form here and descibe the problem!
If your main question got answered then please mark the answer using the button!
Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
casperrutten 3
January 14 2020, 17:50 #390725
Thanks for your reply.
I also had to redo the whole form, entered it exactly as the original. Than it worked again.
The exact problem was that the first time the submit button was pressed, nothing happened. Pressing a second time submitted the form, but the actions did not execute.
Also restoring a backup made before the problem occurred gave the same result.
I can send
you a copy of the last backup I've made.
I suspect that the problem started after restoring a backup version.
Request: is it possible to extend the trail version for a few days? I've lost a lot of time with this problem.
casperrutten 3
January 19 2020, 20:30 #390793
Again, I have the same problem.
When I submit the form the first time, the form reloads with the data without messages (which it should give on field validation). The second time it submits.
I have put a message at the beginning of the submit form. This doesn't display the first submit, but does at the second.
It seems that the first submit doesn't activate the submit form.