Buy Now
Sign in

hit by the Check noCaptcha allow_url_fopen=0 issue

maddix , October 26 at 00:06
m
maddix

Hello all,

I'm seeing a form work OK on my staging server, but fail when deployed to the hosting provider. It uses a reCAPTCHA v2 keypair and the nocaptcha load/check actions for anti-spam. The google animation completes with a green tick, but the fail path is always taken and the form reloads with a red error box with the recaptcha fail error.

Other posts here indicate this is because the code does not fall back to cURL when it finds that file_get_contents() is disallowed on the hosting platform by allow_url_fopen() flag

Is the Custom [GH] nocaptcha check action still available ? I tried a PM to GreyHead Sensei, but, as a new user, the forum won't allow this

Many thanks in advance

Kind Regards

Joomla v3.7.4
Chronoforms v5.0.16

GreyHead

HI Maddix,

I've sent you a PM with a download link.

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

m
maddix

many thanks Bob !