Buy Now
Sign in

Where is the 'Relative URL' setting in the Chronoforms v6 Form Manager GUI ?

pattaya2000 , October 06 2017
P
pattaya2000
I have added a form to a Joomla Content page on my website, using the ChronoForms plug-in to show the form in an article. However, when the form is submitted, the confirmation page does not appear to the visitor. I'm guessing it is because I have enabled built-in Joomla SEF option.

I've read the FAQ at https://www.chronoengine.com/faqs/70-cfv5/5259-my-form-doesn-t-submit-send-emails-save-records.html which says ...


Forms in Articles and Modules

By default, ChronoForms sets the form Action URL to use a 'Relative' URL - that is, it uses the URL for the current page and adds the form name and event to the query string e.g. &chronoform=form_name&event=submit.

This will work correctly provided that the Joomla! Router knows that the URL needs to be submitted to ChronoForms. When this fails then then the form will not submit.

The first solution to try is to turn the 'Relative URL' setting to 'No'. The setting is in the form HTML (Render form) action in the On Load event in the Designer tab in the form editor.


... but I cannot find the 'Relative URL' setting (or equivalent) in the Chronoforms v6 Form Manager GUI ? Where is it please?

Thanks in advance
GreyHead
Hi pattaya2000 ,

Please try adding {url:} to the Action URL and/or parameters box in the Display Section action. I can’t find it in the manual but I think that is the right code.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
P
pattaya2000
That works.

Many thanks Bob!