Buy Now
Sign in

After upgrade to Joomla Version from 3.7.2 to 3.7.3 save of ChronoForm V5 form wipes out Setup code!

MainsailSoftware , July 07 2017, 22:49
MainsailSoftware 198
July 07 2017, 22:49 #370273
Today I tried to update an existing and working form with some minor Setup custom code. It says it saves properly, but when I go back to Setup all the code is missing. Thankfully I had a form backup from May 2017. I reloaded it and the Setup code loaded properly. I then simply tried to save the form without any changes. The same loss of all the Setup code occurred!

Joomla Version 3.7.3
Chronoforms5 Site Plugin V5.0 08.Dec.2013
ChronoForms5 Site Module V5 RC1.2 December 2013
ChronoForms5 Administrator Component 5.0.15 May 2017
ChronoForms5 Package Site Package V5.0 2016
PHP Version 5.6.30

I accept updates from Chronoengine when they appear in Joomla Admin.

HELP! I need to make this minor change soon!
Mbiyc Webmaster
President, Sr. Software Architect, Mainsail Software LLC
MainsailSoftware 198
July 10 2017, 20:19 #370348
I was able to load up a backup of an unused form. I saved it and this time it did not wipe out the Setup code. This appears to have to do with the size of the code. Are you aware of settings I need to set to allow the forms with larger segments of Setup code to load?
Mbiyc Webmaster
President, Sr. Software Architect, Mainsail Software LLC
MainsailSoftware 198
July 10 2017, 21:56 #370351
I turn on Joomla debug to maximum and here is what I am getting:

Save Failed
Notice: Undefined index: extras in /hsphere/local/home/a965916/mbiyc.com/joomla/administrator/components/com_chronoforms5/chronoforms/models/form.php on line 28 Warning: Invalid argument supplied for foreach() in /hsphere/local/home/a965916/mbiyc.com/joomla/administrator/components/com_chronoforms5/chronoforms/models/form.php on line 28 Notice: Undefined index: extras in /hsphere/local/home/a965916/mbiyc.com/joomla/administrator/components/com_chronoforms5/chronoforms/models/form.php on line 149 Warning: Invalid argument supplied for foreach() in /hsphere/local/home/a965916/mbiyc.com/joomla/administrator/components/com_chronoforms5/chronoforms/models/form.php on line 149

I received something very similar with a different form with a large Setup set of code.
Mbiyc Webmaster
President, Sr. Software Architect, Mainsail Software LLC
NickOg 825
July 14 2017, 00:06 #370450
I have hit the same problem. I assumed (with no evidence) a clash between CF5 and CF6 rather than the Jooma update but it is MAJOR PROBLEM.

Please help!!!!!

Nick
NickOg 825
July 14 2017, 00:14 #370451
A bit more information - I am having the problem with PHP7 so it isn't a PHP version problem.

Nick
MainsailSoftware 198
July 14 2017, 00:16 #370452
What I did that resulted in it actually starting to work was as follows:

Set php.ini max_input_vars to 10000 (did this first and with Safe Save disabled it did not work)
Enabled Safe Save with the following settings
Safe save chunk size: 5000
Safe loading count: 15
Display actions diagnostics: Yes
Mbiyc Webmaster
President, Sr. Software Architect, Mainsail Software LLC