Buy Now
Sign in

Getting Blank screen when click =ing form name in manager V6

jjspelman , June 12 2017, 15:04
J
jjspelman 187
June 12 2017, 15:04 #369284
I have been working on a lengthy form that now does not allow access to it when clicking on the form name in the manager. Instead it loads a blank white page. I have10 more of these very long forms to do and really need a fix quickly.

There is plenty of room left for max_vars_input so I know that is not the issue. Please help!

The content here is visible only for authorized users.
admin 29
June 12 2017, 16:30 #369288
Hi jjspelman,

Please try increasing the max processing time and max memory limit settings, this may help hopefully!

Best regards,
Max
GreyHead 64
June 13 2017, 09:40 #369335
Hi jjspelman ,

I took a quick look - all the forms opened OK for me so you may already have found a solution. A blank page is usually a sign of a PHP Error - setting the site error reporting temporarily to Maximum may give a more useful message.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
J
jjspelman 187
June 14 2017, 20:06 #369418
I changed the max processing time, as suggested above. to 60. So now, yes, the form will finally open but it takes 20 seconds. And when I say open, I mean open in the admin area when clicking on the form name so I can edit it. And not when clicking on "Open" to view the form.

I can't work with this. I have never had this issue with V4 or V5 - and these forms all exist already but in V4. So I am trying to rebuild them all in V6 but this is just taking far, far too long. I have max vars set to 10,000 - and the form in question is only using 3925 so far. I have ten of these to do and am not feeling optimistic about it.

Can you guys please have a closer look and suggest something? I have the admin info in my first post.

Otherwise, we may have to seek an alternative solution, which I do NOT want to do. I am very used to ChronoForms and want to stay with it.

Hope you can help!
admin 29
June 14 2017, 22:29 #369427
Hi jjspelman,

The next update should have some improvements regarding this issue, but this only happens with really big forms.

Best regards,
Max
J
jjspelman 187
June 14 2017, 22:45 #369431
When is this update due?
J
jjspelman 187
June 15 2017, 19:23 #369453
We were having major problems with the forms loading from the back end. I contacted HostGator and they were saying it's because the server was running PHP 7 and that it wasn't compatible with Chronoforms? is this correct?
J
jjspelman 187
June 15 2017, 19:43 #369454
Ok fellas, this isn't working either. I am still getting "500 error" when trying to access two forms I created with V6. I have sooo many hours here that I can't possibly bill for.

I can access two other forms because they are relatively small. But the two larger ones (there are 9 more long ones to create) that are using only half of the max_vars (which is set to 10,000) keep throwing a 500 Error when trying to access them to edit. I am creating a very serious problem with my client because they have expected, as did I, to have these forms rebuilt by now. Can you please help?
admin 29
June 15 2017, 22:45 #369458
Hi jjspelman,

v5 has a problem with php 7.1, but v6 no.

Loading a 4000 vars v6 form usually takes around 10 seconds here, this depends on your connection speed to the server, and your browser's available memory, a 500 error means a server error, please open the Joomla global config and set the error reporting to "maximum" then try to edit the form, does it show any error ?

You wrote before that increasing the max execution time solved the problem, but is this broken again now ?

Best regards,
Max
J
jjspelman 187
June 15 2017, 23:00 #369461
Yes I made those adjustments to php.ini and it seemed to help - but as the form grew so did the issue. Now I am just getting 500 errors. Of course, HostGator says it's Joomla and ChronoForms.

I turned max error reporting but there is no error shown because it defaults to a 500 error page
admin 29
June 15 2017, 23:07 #369462
Ok, please ask hostgator to check the error log and find the real error message behind the 500 error ?

I have worked with 4000+ vars forms and they loaded fine, hopefully the new update will be ready soon, I can also give you a dirty hack which can decrease the vars number if this okay for you ? it would have one of the effects of the next update but not the clean way, this is until the new update is ready.

Open this file:
JOOMLA\libraries\cegcore2\admin\themes\default\views\permissions_manager.php

And find line 6:
ob_start();


and add this before it:
return;


Best regards,
Max
J
jjspelman 187
June 15 2017, 23:18 #369463
When they checked the error logs the said it was due to us running PHP 7, and they said it looks like the forms were using an older version. So they set it back to 5.6. But this didn't work either.

I have made the change to the permissions file as instructed but it didn't help.
admin 29
June 16 2017, 21:47 #369496
Hi jjspelman,

The PHP version does not affect v6, please ask them about the PHP error message causing the 500 error, this is the key to find out the source of the issue.

Did not the vars number of the forms change after the code change ?

Best regards,
Max
J
jjspelman 187
June 20 2017, 17:16 #369616
Any news on the update Max? I am really in a bind here.

The server says it's running php 5.6, but Joomla System Info says it's PHP 7.0.18 - yet the extensino_dir path is /opt/php56/lib/php/extensions etc.

max var is still set at 10,000

What can this mean?
admin 29
June 20 2017, 21:54 #369619
Hi jjspelman,

The php version detected by Joomla is what matters, what about the execution time settings detected by Joomla ?

The code change done should already improve the performance, I have just logged in, tried to edit the last 2 forms, both worked fine, the last form took about 10-15 seconds to load but this is ok since you have lots of fields inside, the next update may reduce this time further but not much.

Best regards,
Max