Buy Now
Sign in

Multi file Upload Mail - No File Attachment in Mail

Olekk , May 03 2017, 00:55
O
Olekk 19
May 03 2017, 00:55 #367689
Hello,
I have a problem with chronoform v6 mail attachment. Maybe somebody can help me.

My setup:
Designer-Tab: I have setup a form with a file field, multi file select is "multi section" and the name is file9[]

Setup-Tab: in the upload section in the file config is: file9:jpg

In the E-mail section is under Attachments list: {var:upload8.file9.path}

When I submit this the upload to the server works well, but in the mail is no attachment.

When I setup the form with single file (changed name to file9) it works fine and theres an attachment in the mail.

Is there any faq about this?

Kind regards,
Olekk
admin 28
May 03 2017, 11:06 #367696
Hi Olekk,

Since this is a multi file upload, the files are listed as an array under: {var:upload8.file9} and so the attachment string should be like this:

{var:upload8.file9.[n].path}


But that still would not work before the next update which is supposed to be ready in the next few hours hopefully.

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!
Did you try the new ChronoForms7 ? if yes then please send us your comments!!
O
Olekk 19
May 03 2017, 17:19 #367710
Hi Max,

ok, thank you for your fast reply.

So I will wait for the next update an try again.

Best regards
Olekk
O
Olekk 19
May 16 2017, 13:25 #368221
Hi Max,

ok, now it works fine - thank you. But it`s not possible to upload a JPG file that is bigger than 1.5 MB.

I allready set the max size to 10.000 KB (3 Setup - Upload files section). In the joomla Media Setup there is also the 10MB Limit activated.

When I try to send a file >1.5 MB the form reloads with loosing the file selection. An error message didn!t appear.

Is there a basic limit setting I missed?

Best regards
Oli
admin 28
May 16 2017, 21:19 #368248
Hi Oli,

What is the maximum size in the upload action ? is it "10000" or "10.000" ?

What about single file upload, does it have the same size problem ?

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!
Did you try the new ChronoForms7 ? if yes then please send us your comments!!
O
Olekk 19
May 19 2017, 06:03 #368325
 1
 Answer
Hi Max,

thank you for the fast reply. it was a server problem. I set the mail upload and post values in the php.ini to 15M an now it works fine.
have a nice day!