Buy Now
Sign in

SmartSearch indexing and the Chronoforms5 plugin

acmfox , August 19 2016
a
acmfox

After realizing that SmartSearch was not fully indexing the site, I ran the CLI version in order to track down what was going on and received these error messages:

				Notice: Undefined index: trans_type in /.../administrator/components/com_chronoforms5/chronoforms/actions/html/html.php(263) : eval()'d code on line 16

Notice: Undefined index: trans_type in /.../administrator/components/com_chronoforms5/chronoforms/actions/html/html.php(263) : eval()'d code on line 18


The page that was referenced included the Chronoforms plugin to reference one of my forms which includes custom php code and I think that trying to index this code -- which is not what should happen: it should be indexing the html that the code produces -- is what causes the problem. Temporarily unpublishing the Chronoforms plugin allows the indexing to complete normally.

I don't know which I'd assign to attempt to fix this problem: whether the problem belongs to SmartSearch or ChronoForms, It's (hopefully) a fairly unusual situation. I note it here mainly as a heads-up for anyone else who encounters this situation.

As always, thanks for a great piece of software.

GreyHead

Hi acmfox,

Sorry, I don't have the slightest idea :-( The code is evaluated on page load so the HTML doesn't exist until that happens. I don't know anything about SmartSearch - maybe it has an option to skip PHP?

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much