Buy Now
Sign in

Chrono Forms 5.0.10 will not install to Joomla 3.4.4

ccondo , September 25 2015, 02:04
C
ccondo 42
September 25 2015, 02:04 #351960
When I go to install it says:
An error has occurred.
0 Could not connect to MySQL.

I have tried to install from a dir on the server and it also failed. I checked my mySQL database username and password and reset them for good measure and it still will not install. I also restarted mySQL on the server and no luck.

Just to see if anything else would install I was able to install the Chrono Forms module and it worked.

Please advise.
GreyHead 64
September 25 2015, 05:48 #351961
Hi ccondo,

What version of MySQL are you using?

Do you see any errors if you set site error reporting to Maximum temporarily?

Normally installation is no problem, we have seen some errors with some less common versions of SQL. From memory I think with PostGreSQL and with MSSQL. In these cases installing the tables directly seems to solve the problem.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
C
ccondo 42
September 29 2015, 02:14 #352058
It is mySQL: 5.6.22-cll-lve - MySQL Community Server (GPL)

Here is the Joomla errors:
An error has occurred.
0 Could not connect to MySQL.
Call stack
#  Function  Location
1  JApplicationCms->execute()  /home/gssonline/public_html/administrator/index.php:47
2  JApplicationAdministrator->doExecute()  /home/gssonline/public_html/libraries/cms/application/cms.php:252
3  JApplicationAdministrator->dispatch()  /home/gssonline/public_html/libraries/cms/application/administrator.php:152
4  JComponentHelper::renderComponent()  /home/gssonline/public_html/libraries/cms/application/administrator.php:98
5  JComponentHelper::executeComponent()  /home/gssonline/public_html/libraries/cms/component/helper.php:372
6  require_once()  /home/gssonline/public_html/libraries/cms/component/helper.php:392
7  JoomlaGCLoader->__construct()  /home/gssonline/public_html/administrator/components/com_chronoforms5/chronoforms5.php:17
8  GCore\Libs\AppJ::call()  /home/gssonline/public_html/libraries/cegcore/joomla_gcloader.php:104
9  GCore\Libs\AppJ->dispatch()  /home/gssonline/public_html/libraries/cegcore/libs/app_j.php:444
10  GCore\Libs\Event::trigger()  /home/gssonline/public_html/libraries/cegcore/libs/app_j.php:112
11  GCore\Libs\Event::get_extensions()  /home/gssonline/public_html/libraries/cegcore/libs/event.php:35
12  GCore\Libs\Model::getInstance()  /home/gssonline/public_html/libraries/cegcore/libs/event.php:17
13  GCore\Libs\Model->__construct()  /home/gssonline/public_html/libraries/cegcore/libs/model.php:120
14  GCore\Libs\Model->loadFields()  /home/gssonline/public_html/libraries/cegcore/libs/model.php:72
15  GCore\Libs\DatabaseObject->getTableColumns()  /home/gssonline/public_html/libraries/cegcore/libs/model.php:185
16  GCore\Libs\DatabaseAdapters\Joomla->_getTableInfo()  /home/gssonline/public_html/libraries/cegcore/libs/database_object.php:97
17  GCore\Libs\DatabaseAdapters\Joomla->loadAssocList()  /home/gssonline/public_html/libraries/cegcore/libs/database_adapters/joomla.php:41
18  JDatabaseDriver->loadAssocList()  /home/gssonline/public_html/libraries/cegcore/libs/database_adapters/joomla.php:48
19  JDatabaseDriverMysql->connect()  /home/gssonline/public_html/libraries/joomla/database/driver.php:1118
GreyHead 64
September 29 2015, 08:43 #352062
Hi ccondo,

Nothing obvious there, The error is happening in the Joomla! driver code. It may be that your site is configured to use the mysql driver and not mysqli, you can check that in the dbtype setting in the System Information > Configuration file tab.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
C
ccondo 42
October 06 2015, 16:34 #352292
I checked and I am using the MYSQLi driver:

From the config file:
dbtype   mysqli
C
ccondo 42
October 06 2015, 16:36 #352293
Is there an old version somewhere that I might be able to install it?
GreyHead 64
October 08 2015, 11:03 #352334
Hi ccondo,

You can use the Contact Us menu above to ask Max for an earlier release of CFv5, or you can download and try CFv4. I rather doubt if this will solve your problem though. Have you checked with your web-host to see if they have any clues?

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
C
ccondo 42
October 13 2015, 18:25 #352462
We have found a work-around to this issue - We went in to Joomla and changed the database type to be MySQL PDO and it installed fine. We then later tried to switch it back to MYSQLi and it will break the front end website that has chronoforms on it and will break the back end with the same mySQL connect error.

On the page with the form it will say:
Cant render position
GreyHead 64
October 13 2015, 19:04 #352464
Hi ccondo,

Thanks for letting us know - I just checked and my site is running MySQLi OK. I can only guess that there is some combination of settings that is causing indigestion on yours :-(

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much