Buy Now
Sign in

fatal Error chrono form Wizard

nichola , October 31 2013, 07:09
N
nichola 22
October 31 2013, 07:09 #318693
When i access the wizard edit button i get the following error
Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 3708604 bytes) in /home/bcadebtc/public_html/libraries/phputf8/mbstring/core.php on line 121
I don't know what to do with this my php.ini file has 64m memory
GreyHead 64
October 31 2013, 13:20 #318716
Hi nichola,

Something is putting Joomla! into a loop. The server logs might give you a clue. If this is happening just with one form there's probably a bug somewhere in the form code. If it is happening with all forms then my best guess would be that there is some kind of server security setting that is causing it.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
N
nichola 22
October 31 2013, 23:11 #318738
thanks for reply,
the problem is happening on all forms, could it have anything to do with upgrade on admins tools? is there some sort of access i need to give chrono forms in there?
GreyHead 64
November 01 2013, 09:34 #318752
Hi nichola,

Please try disabling Admin Tools to see if that makes a difference.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
N
nichola 22
November 04 2013, 09:07 #318882
Disabling admin tools worked
Is there a fix for this problem or do i just live with it?

cheers Nichola
GreyHead 64
November 04 2013, 09:48 #318886
Hi nichola,

Impossible to say without hunting down the exact cause of the problem :-(

The simplest practical solution is to turn off Admin Tools when you need to work with ChronoForms. Not ideal but probably less work than any alternative.

Is this the Akeeba Admin Tools extension or another one?

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
N
nichola 22
November 07 2013, 07:14 #319040
Thanks for reply will do that, however when i try to work on the form i now get this error when saving the form.

Warning: mysqli_fetch_row() expects parameter 1 to be mysqli_result, boolean given in /home/bcadebtc/public_html/libraries/joomla/database/driver/mysqli.php on line 748

Warning: mysqli_free_result() expects parameter 1 to be mysqli_result, boolean given in /home/bcadebtc/public_html/libraries/joomla/database/driver/mysqli.php on line 791
GreyHead 64
November 07 2013, 13:22 #319071
Hi nichola,

These are PHP warnings (not technically errors) so if you set the Site Error Reporting to System Default or None in the Global Configuration they should be hidden.

The warnings are showing up in the Joomla! db code, and I don't remember seeing them from ChronoForms before. If you need to diagnose then turning Site debug on will dump the MySQL queries and might give a clue.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
N
nichola 22
November 10 2013, 02:26 #319278
Hi there,
i did what you suggested in the last post, since then i have done the joomla update now have this error


Warning: require_once(/home/bcadebtc/public_html/administrator/components/com_chronoforms/versions/j3.2/admin.chronoforms.php) [function.require-once]: failed to open stream: No such file or directory in /home/bcadebtc/public_html/administrator/components/com_chronoforms/admin.chronoforms.php on line 19

Fatal error: require_once() [function.require]: Failed opening required '/home/bcadebtc/public_html/administrator/components/com_chronoforms/versions/j3.2/admin.chronoforms.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/bcadebtc/public_html/administrator/components/com_chronoforms/admin.chronoforms.php on line 19
GreyHead 64
November 10 2013, 18:22 #319304
Hi nichola,

Please upgrade the the latest release of ChronoForms for Joomla! 3 (and the plug-in and module too if you use them). They have fixed this problem and a few others.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
N
nichola 22
November 11 2013, 04:27 #319345
Dear Bob,
thanks for reply i have done the upgrade and am now able to access chronoforms, however i am now back to the original error, but using the original fix of disabling Admin tools did not work.

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 3484711 bytes) in /home/bcadebtc/public_html/libraries/phputf8/mbstring/core.php on line 121
GreyHead 64
November 11 2013, 11:48 #319378
Hi nichola,

It looks as though you have a different error now :-(

That one is usually caused by a code loop somewhere. Turning Site Debug on or checking the server logs may give you a clue about where it is originating. Unfortunately the message only tells you want was running at the point the last memory was used.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
N
nichola 22
November 19 2013, 05:48 #319701
fixed fatal error, it was the magic_quotes that needed to be turned off with the new version of Joomla.
Only thing is now it wont save the forms wizard, when you save it kicks you out to the control panel.
cheers
GreyHead 64
November 20 2013, 14:24 #319812
Hi Nichola,

That behaviour is usually because the PHP Max_input_vars setting is too small, if it is set to the default 1000 please try increasing it to 2000 or 3000.

Bob

PS Magic Quotes is now deprecated I think.
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
N
nichola 22
November 21 2013, 07:02 #319839
Cheers,
do you know if safe mode should be turned off for the new version of Joomla 3
GreyHead 64
November 21 2013, 09:42 #319844
Hi Nicola,

I found this in the Joomla! docs, as it is removed from PHP 5.3 I would leave it off if you are still using 5.2

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much