Buy Now
Sign in

CF6 errors with PHP 7.4, and converting CF6 Forms to CF7

tshirley , August 21 2021, 03:16
T
tshirley 327
August 21 2021, 03:16 #396966
Hi,
We have a stable CF6 environment, however recently we saw advice from Joomla that we should upgrade from PHP 7.2 to 7.4 or higher. After doing this some of our CF6 forms crashed with the following error:
l!J DOMXPath::query(): Invalid expression in selector >> body << in /home/admingliding/public_html/libraries/cegcore2/vendors/emogrifier/Emogrifier.php
on line 371
Although this doesn't seem like a CF6 error, it only occurred in some CF6 forms and not others, didn't happen on any other parts of the site, and it went away when we reverted the PHP upgrade.
Is CF6 incompatible with PHP versions 7.3 and beyond? If it is, then the next question is whether we need to redevelop our forms in CF7, and if there are any tools that would assist this process.
Cheers
D
DuW 18
October 01 2021, 10:35 #397173
Hi,
we also have issues with the new php version.
We are using CF6 and now want to upgrade to CF7 but there is no way to import cf6-files.
Kind regards
Susan
GreyHead 65
October 02 2021, 10:15 #397180
Hi,
At present neither CFv6 or CFv7 are fully compatible with PHP v7.3+; and Susan is correct there is no way to import CFv6 files into CFv7 (there is for CFv5).
Max - the owner and developer - has been absent for some months now, hopefully he will be back soon and will resolve these problems.
Bob
If you'd like to buy me a coffee or two, thank you very much
D
DuW 18
October 05 2021, 07:45 #397191
Thank you very much for your information. I am sad to hear that and hope that everything is fine with Max.
R
rotocal 51
May 18 2022, 18:20 #398417
Hi I have some old forms still in CF V5 .. despite of I have also CF6 and CF7. By changing PHP version from 7.3 to 7.4 I am receiving this error message when I try to edit a CF5 form : 0 syntax error, unexpected 'Fn' (T_FN), expecting identifier (T_STRING).
Should I come back to PHP 7.3 and try to convert the old CF5 forms to CF7? ... Some of them have heavy PHP + Mysql in inside.... or Is there a way to back up forms and read with CF6 or CF7?
GreyHead 65
May 19 2022, 09:22 #398422
Hi Rotocal,
There is a fix for the 'syntax error' in this FAQ along with some others.
You can back up your forms in CFv5 and restore them in CFv7 - though some extra work will probably be needed.
Bob
If you'd like to buy me a coffee or two, thank you very much
R
rotocal 51
May 20 2022, 15:33 #398425
Thank you very much for your prompt answer