Buy Now
Sign in

Field show or hide does not work

Ronn , December 09 2020, 13:21
Ronn 469
December 09 2020, 13:21 #395232
Hello,
I have this test form that I am checking. It works okay on one domain but not on the other. I am attaching the form... I don't find an error anywhere. I feel there is a conflict in the forms js script with the website js scripts.
I have attached the form. If I am making a mistake somewhere please point out. But it works okay in Admin view. I feel it could be a bug.
Best wishes
Ronn

I don't know if there is heaven... But yes... I believe in Angels...
Ronn 469
December 09 2020, 13:22 #395233
Attached form
Attachments
test_09_Dec_2020.cf7bak
(1.89 KiB)
197 Downloads/Views
Best wishes
Ronn

I don't know if there is heaven... But yes... I believe in Angels...
Ronn 469
December 16 2020, 08:14 #395347
Hello
Is this a bug or am I making a mistake somewhere ??
Best wishes
Ronn

I don't know if there is heaven... But yes... I believe in Angels...
admin 33
December 19 2020, 01:35 #395392
 1
 Answer
I have just tested the form, it works fine on both admin and front, assuming you test with a validated install, because the countries list requires a valid install!
P
PaulSandman 31
September 20 2022, 12:30 #398912
I am sorry but this problem was affecting me. I could hide and show a multifield area using a toggle switch (checkbox) and see it works in Admin View.
In Frontend there are no labels on toggle switches and switching them shows the Hidden multifield area but does not close it when switching back "off/left"
Update: ** a plugin was causing this. I was not thinking. Front End Javascipt can cause thing to not work so it is importatn that you test in both Admin and Frontend...
GreyHead 65
September 20 2022, 12:47 #398913
 1
Hi Paul,
Most likely there is a JavaScript error in the front end, you can use your browser Web Developer tools to check.
Bob