Buy Now
Sign in

Issue with other plugins that use Joomla! Core-Scripts

dbi , November 14 2019, 13:54
D
dbi 2
November 14 2019, 13:54 #390002
Hi!
I have a problem with some scripts from regular labs.
It causing the error below:
semantic.min.js:11 Tab: The method you called is not defined ["show"]
error @ semantic.min.js:11
(anonymous) @ semantic.min.js:11
each @ jquery.min.js:2
invoke @ semantic.min.js:11
(anonymous) @ semantic.min.js:11
each @ jquery.min.js:2
each @ jquery.min.js:2
e.fn.tab @ semantic.min.js:11
show @ script.min.js?v=7.5.10.p:10
(anonymous) @ script.min.js?v=7.5.10.p:52
dispatch @ jquery.min.js:2
u @ jquery.min.js:2
According to the forum there, there's a problem with a library:
It's related to ChronoForms, which uses the cegcore2 library, which causes conflict.
This is down to a conflict between Semantic-UI (which Chronoforms loads through the cegcore2 library) and Bootstrap (which comes with Joomla core).Semantic-UI tries to reference/overrule the jQuery.fn.tab object (and also jQuery.fn.modal object) which Bootstrap also uses.So in other words:Chronoforms is loading scripts that are incompatible with scripts that come with Joomla itself.So any extension that uses this Joomla core script functionality (Bootstrap tabs / modals) will break because of the Semantic-UI library Chronoforms is loading. This is something that should be fixed by Chronoforms.
Can you tell me what to do?
I'm using your software and regular labs-software on a lot of sites. would be great if you can tell me what to do.
Thank you in advance!
Greets from Austria, Didi
D
dbi 2
December 13 2019, 09:23 #390341
Any answer or comment please.