Buy Now
Sign in

Forms are not sending email after move to another host

kevint8 , May 11 2019, 15:34
K
kevint8 13
May 11 2019, 15:34 #386778
Hello, we need help with a strange issue with Chronoforms v5 for WordPress.
We recently had to move our website to another server and after the move, we are not receiving any email from the form submissions. It was working before on the old server and there was no changes made. Form submitted without any error and the submitted form data is saved to the database, but no email. We have the DB Save action set after the Email action.
We also made sure that SMTP port is not blocked by using another WordPress form plugin to send a test email and receive the test email just fine.
We checked the PHP error logs and don't see anything that stands out. Any ideas what the issue is?
admin 29
May 12 2019, 16:27 #386813
You can try to enable the form debug and check the debug results, your email from/to address can also affect the delivery, make sure it matches the email you received from the other plugin.
Best regards
Max
If your main question got answered then please mark the answer using the button!
Did you try the new ChronoForms7 ? if yes then please send us your comments!!
K
kevint8 13
May 13 2019, 20:31 #386830
How do you enable the form debug?
GreyHead 64
May 14 2019, 08:28 #386834
Hi kevint8,
Please drag a Debugger action into the On Submit event, then submit the form and post the debug - including the 'dummy emails' results here.
Note: if you are using the Easy Wizard you can turn on Debug on the Setup tab in CFv5.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
K
kevint8 13
May 14 2019, 15:57 #386842
Hi Bob,
Thanks for for the tips on enabling debug.
So, I added the Debugger action to the On Submit event as suggested but I am not able to save the form. It is throwing all kinds of errors in the PHP error log.
[Tue May 14 15:21:24.203132 2019] [php7:warn] [pid 19767] [client x.x.x.x:54535] PHP Warning: Illegal string offset 'check_nocaptcha_11' in /[removed]/wp-content/plugins/chronoforms/cegcore/libs/arr.php(60) : eval()'d code on line 1, referer: https://[removed]/wp-admin/index.php?page=Chronoforms5&act=edit&id=12
[Tue May 14 15:21:24.203165 2019] [php7:error] [pid 19767] [client x.x.x.x:54535] PHP Fatal error: Uncaught Error: Cannot use string offset as an array in /[removed]/wp-content/plugins/chronoforms/cegcore/libs/arr.php(60) : eval()'d code:1\nStack trace:\n#0 /[removed]/wp-content/plugins/chronoforms/cegcore/libs/arr.php(60): eval()\n#1 /[removed]/plugins/chronoforms/admin/chronoforms/chronoforms.php(184): GCore\\Libs\\Arr::setVal(Array, Array, '')\n#2 /[removed]/wp-content/plugins/chronoforms/cegcore/libs/app_wp.php(246): GCore\\Admin\\Extensions\\Chronoforms\\Chronoforms->save()\n#3 /[removed]/wp-content/plugins/chronoforms/cegcore/libs/app_wp.php(437): GCore\\Libs\\AppWp->dispatch(true)\n#4 /[removed]/wp-content/plugins/chronoforms/wordpress_gcloader.php(85): GCore\\Libs\\AppWp::call('admin', 'chronoforms', '', 'save', Array)\n#5 /[removed]/wp-conten in /[removed]/wp-content/plugins/chronoforms/cegcore/libs/arr.php(60) : eval()'d code on line 1, referer: https://[removed]/wp-admin/index.php?page=Chronoforms5&act=edit&id=12
I was running PHP 7.0 on the old server and now PHP 7.3.5 on the new server. Seems like Chronoforms is broken because I tried creating a new form and it won't allow me to save if I add any actions to the Setup tab. I should say it does allow me to save but when I reopen the form the Setup tab is empty again. Compatibility issue with PHP 7.3.5?
healyhatman 9
May 15 2019, 02:43 #386845
Have you tried reinstalling CF?
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store