Buy Now
Sign in

Upgraded to PHP 7.2 and cannot save/modify forms.

tschoch , January 21 at 17:40
T
tschoch 15
January 21 at 17:40 #383100
Hi, we just upgraded to PHP 7.2 and are now receiving the following errors when trying to save/modify forms: (removed full path)
Fatal error: Uncaught Error: Cannot use string offset as an array in /home/xxxx/public_html/wp-content/plugins/chronoforms/cegcore/libs/arr.php(60) : eval()'d code:1
Stack trace:
#0
/home/xxxx/public_html/wp-content/plugins/chronoforms/cegcore/libs/arr.php(60):
eval()
#1
/home/xxxx/public_html/wp-content/plugins/chronoforms/admin/chronoforms/chronoforms.php(184):
GCore\Libs\Arr::setVal(Array, Array, '')
#2
/home/xxx/public_html/wp-content/plugins/chronoforms/cegcore/libs/app_wp.php(246):
GCore\Admin\Extensions\Chronoforms\Chronoforms->save()
#3
/home/xxx/public_html/wp-content/plugins/chronoforms/cegcore/libs/app_wp.php(437):
GCore\Libs\AppWp->dispatch(true)
#4
/home/xxx/public_html/wp-content/plugins/chronoforms/wordpress_gcloader.php(85):
GCore\Libs\AppWp::call('admin', 'chronoforms', '', 'save', Array)
#5
/home/xxx/public_html/wp-content/plugins/chronoforms/chronoforms5.php(86):
WordpressGCLoader->__construct('admin', 'chronoforms',
'chronoforms')
#6 /home/xxx/public_html/wp-include in /home/xxx/public_html/wp-content/plugins/chronoforms/cegcore/libs/arr.php(60) : eval()'d code on line 1
GreyHead 63.5
January 21 at 18:46 #383103
Hi tschoch,
Please make sure that you have the latest release of CFv5 installed.
If necessary, there is a fix for this error - I think - in this thread.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
T
tschoch 15
January 21 at 19:11 #383109
Thanks! We are running 5.0.17 which is saying that's the latest. We made the changes in the thread and worked.

Thanks!