Buy Now
Sign in

On table view, columns don't show when in column list, but they do "Include all the provider fields" is checked.

farscape , June 14 at 00:53
F
farscape
I have a simple connection set up as a learning exercise. Everything works except for one thing. I am using a table view, and I want to list the three specific columns to display, with headers defined, but only the headers appear. I've tried everything I can think of, but the only way I see all three columns is with the "include all provider fields" checked, but I can't seem to find a way to customize the column headers using that option. Thanks in advance!
Here is the read data function:
CC6_columns2.JPG
Here is the view (I have tried with "include form?" on and off. No difference in the results.
CC6_columns1.JPG
I see the data in the debugger:
CC6_columns4.JPG
However, the table view shows values in only the first column:
CC6_columns3.JPG
If I check the "include all the provider fields" option, all three columns of data appear, but I can't customize the headers (the data shown is as expected with my test table):
CC6_columns5.JPG
GreyHead
Hi farscape,
Have you tried adding the label at the end of the field list entry - see the note under the box : ​
​"Write each field name or path in the data set and its label, example: Model.field_name:Label"
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
F
farscape
Hi Greyhead,
Yes. I show one attempt in the second screenshot above. That shows labels that are the same as the column names, but I've also tried labels that didn't match the column names. too. No difference.
Bill
GreyHead
Hi Bill,
I suggest that you ask Max for his input using the Contact link above and linking to this thread - my CCv6 knowledge is still pretty limited.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
F
farscape
Will do. And I just realized that I posted this to the wrong forum. Sorry!