Buy Now
Sign in

How to send user activation link in email and activate user when clicked?

SplodeForms , April 12 at 03:19
S
SplodeForms
Frustrated again.
After a user registers using my CF V6 form how can I send an activation link in an email? How do set up to react to the link being clicked. How do I construct the link?
Why is there so little information about this in the forums (for V6) and none in the manual? Why is there no demo of a registration system using CF V6? Why is there no solid "how to" for this.
If I get this registration system working I will gladly provide it so other CF V6 users can use it but I've hit a wall now. Wild guesses about what the fields and tools do is not getting me anywhere so I need help.
Is this the way it will be for a log in form? No demo? Little info.? There should be much better support for registration and login both in tools and documentation.
GreyHead
Hi SplodeForms,
If you are using the Save User action that will generate an Activation Code for you and should then trigger the Joomla Registration code to send the email to the user.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
S
SplodeForms
I put the Save User action in and it creates a new user. No activation email is sent to the new user nor an announcement to admin. Joomla's user activation is set to "self" and I checked the Joomla email set up in Global Configuration->Server->Mail Settings. It is correct and I used the test button there and it worked.
If I understand your reply, using the Save User action will cause Joomla to send the activation email. The email is not being sent.
In Save User:
- I set "Blocked status provider" to 0. That made new user Enabled but no change to email situation. Should that be 1 or 0?
- Activation code provider is {uuid:} by default. Is that correct? What is this? How is it used?
- Groups ids provider is {value:[2]} by default. What is that? How does it work and what value should it have?
GreyHead
Hi SplodeForms
That is certainly how the Save User action should work - I don't know enough about CFv6 or the latest Joomla! version to know if there is a bug . Max is more likely to be aware if there is.
You want Blocked status provider set to 1 - that keeps the user blocked until they have activated themselves.
The {uuid:} generates a random string for the validation code.
The {value:[2]} - I think - sets the User Group to 2.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
S
SplodeForms
Thanks GreyHead.
I activated the regular Joomla login/registration tool and registered a new user. The validation email and admin. notification email worked. So that eliminates that I set up something related wrong in Joomla or a bug in Joomla. I'll contact Max.
admin
Hi,
In v6 the "Save user" action does not send notification emails, it just "saves the user", you can add email actions to simulate the emails sent, for the user email you can use {data:email} in the "Rcipients" setting to send it to the email address in the form (the user email), assuming the email field name is "email"
Best regards
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
M
mediandmore
I have the same question...
The Joomla default activation email generates an URL like http://DOMAIN/index.php?task=registration.activate&token=ACTIVATION_CODE
Where ACTIVATION_CODE is {uuid:} from the Save User Action.
Even if I print {uuid:} in the email to the user, the activation link doesn't work.