Buy Now
Sign in

TCPDF Page Break & visual editor

coughlin , November 21 2017
C
coughlin
In a previous support post you suggested adding
<br pagebreak="true"/>
to the html of the TCPDF action. So here is what I have done:

1. Click on TCPDF action
    in the Setup Tab
    2. Click on the HTML butt
on of the visual editor
3. Enter the pagebreak code
4. Save the form

NOTE: the Visual editor STRIPS the pagebreak code.

IF you turn OFF the visual editor, you CAN add the pagebreak code and it does work. However, if at any point after that you enable the visual editor, it will remove all of the page breaks.

Is there a way to get the visual editor to allow that code?
C
coughlin
Is there any way to change this behavior? Any time we open the form for editing, the WYSIWYG editor is enabled, so if we forget to turn it off the code gets stripped and we have to copy/paste the TCPDF code in again.
GreyHead
Hi coughlin ,

I haven't yet tried the TCPDF in CFv6 so I'm not certain that this will work. You could try defining the pagebreak string in a form variable then add that to the TCPDF template - hopefully CF will then insert the correct code.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much