Buy Now
Sign in

Thank you message not showing any more in Joomla 3.8.2.

mojzi , November 15 2017
Answered
m
mojzi

Hi,

I am using Chronoforms5 for two years, now, and it worked fine. Including the "thank you" message. Now I was told, that the "thank you" message does not work any more. What have I done in the last weeks?
- I changed JSN Dome 1 Template to JSN Dome 2 Template (to be ready for Joomla Update 3.8.x
- Updated to the latest Joomla Version 3.8.2 (I am always on the latest version).

This is the site, where the Chronoforms5 form is implicated: https://www.oceanspirit.at/schweden-yachtcharter2-g/yachtcharter-schweden.html#CharteranfrageSchweden2

This is the thank you message, as it is shown now: https://www.oceanspirit.at/index.php?option=com_chronoforms5&chronoform=Schweden_Yachtcharter

Did I miss to modify a link etc. when updating Joomla Version 3.8.2? Can the update to Joomla 3.8.2 can be the reason for the not working "thank you" message? A module assignement in the new template? I have no idea.... In Chronoforms5 I have not changed anything, so any hint would help me a lot.

Thank you,

Werner

GreyHead

Hi Werner,

The second link shows an error.

Does the form submit from the Test Form link in the Forms Manager?

I suspect that this might be a problem with SEF URLs but hard to tell so far.

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

m
mojzi

Hi Bob,

yes, only the second link is the problem.

Entering data in the form works, sending emails (to me and the one who entered data in the form) works, everything is saved in the database - that works all.

All works, like it did the approximately last two years, since I use v5.

The last step in the setup, after "DB Save", is the thank you message. This is the only point which does not work any more. I have only updated the template, and did a "routine" Joomla update to 3.8.2. I did not change anything to Chronoforms.

SEFURLs I use - but for years, now. And that worked with Chronoform. Is there any other way to display a thank you message? Everything is better than this error message....

Thank you,

Werner

GreyHead

Hi Werner,

I can't see why the form would load from the article but not from the direct link. Please try setting site Error Reporting to Maximum temporarily and see if you then get a more helpful error message.

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

m
mojzi

Hi Bob,

I set Error Reporting on Maximum - but nothing happens. Same error message / site appears. No hint, nothing.

Can I modify any file / code etc. manually, to improve the result? In any way...

At the moment I have no idea, how to find a solution.

Thank you,

Werner

GreyHead

Hi Werner,

By all means PM me the site URL, the form name, and a SuperAdmin login and I'll take a quick look.

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

GreyHead

Hi Werner,

I got a test form to load - though it wasn't visible. However there are about 600 Javascript warning messages on the page from your compression module. I suggest that you try disabling that and see if it fixes the problem.

				<b>Warning</b>:  in_array() expects parameter 2 to be array, null given in <b>/www/htdocs/w008dc43/plugins/system/sunfw/includes/site/compress/js.php</b> on line <b>432</b><br>
<br>
<b>Notice</b>: Undefined index: js in <b>/www/htdocs/w008dc43/plugins/system/sunfw/includes/site/compress/js.php</b> on line <b>432</b><br>
<br>
<b>Warning</b>: in_array() expects parameter 2 to be array, null given in <b>/www/htdocs/w008dc43/plugins/system/sunfw/includes/site/compress/js.php</b> on line <b>432</b><br>
<br>
<b>Notice</b>: Undefined index: js in <b>/www/htdocs/w008dc43/plugins/system/sunfw/includes/site/compress/js.php</b> on line <b>432</b><br>
The error message you are getting seems most likley to be from something that is not compatible with PHP 7.0 - as far as I can see your ChronoForms components are up to date and should be OK

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

m
mojzi

Thank you Bob, for checking and finding out that.

I have contacted the support of JSN, they cannot help (they ask for a video detail, as they cannot recreat the bug). I cannot do that, and you have already done so much.

I disabled all compression on the website (in Joomla configuration and in the template) - still the same problem.
I deleted the "thank you page" (display message) - and the problem remains.

No idea... maybe I have to live with that. I cannot solve it, not nice for my clients, but maybe it is as it is, as it is the only problem at the moment I have discovered.

Thank you for all your support,

Werner

m
mojzi

Hi Bob,

this issue is solved, it was a JSN template problem (if someone has a similar issue).

Thank you,

Werner

admin

Hi Werner,

It should be helpful if you can post a hint on the problem and how you fixed it in case other users have the same issue! :)

Best regards

Max
If your main question got answered then please mark the answer using the button!

m
mojzi

Hi Max,

I asked the support of JSN (Dome template) for help, and they did something on the website. I wouldn't be able to handle this problem (no idea where to start from). Well, I don't know, if this helps, but the solution was found and executed by JSN support.

Werner

admin

Hi Werner,

Ok, no problems!

Best regards

Max
If your main question got answered then please mark the answer using the button!