Buy Now
Sign in

cegcore2's library are not loading when the K2 cach is not empty

yorai85 , November 15 2017
Y
yorai85
hello,

there is a strange bug in one of my forms.
i'm loading a form inside a k2 item with the ChronoForms6 plugin - if the form is loaded when the cach is NOT empty (specificly the k2 cach), then the cegcore2 filles are not loading - preventing the form from submitting or even displaying the right design.

when loading the page with the form after clearing the website cach everyting is ok. but when the cach is not empty, the cegcore2 libraries are not loading.
after testing i found that this problem is with the "k2" cach (not the "k2 extended" but the regular "k2" cach).

please see attached screenshots from Chrome's dev-tools.
on the first one, the 'sources' tab is showing the filles. this is after clearing the k2 cach.
the second image show the sources tab for the same page, after reloading when the k2 cach is full.

i understand that this bug might be related to k2 and not Chronoforms, but i hope that you might have a fix for this.
any advice would be highly appriciated.

thank you
yorai
Attachments
cegcore2-library-not-found.png
cegcore2-library-not-found.png
(47.84 KiB)
606 Downloads/Views
cegcore2-library-found.png
cegcore2-library-found.png
(48.2 KiB)
630 Downloads/Views
jj135
I had a similar issue with a from and the Joomla cache. But only when using the CF plugin inside an article. Not when loading the form from a menu item. I think the caching of an article causes issues with the CF6 plugin.

The same thing happend when I created a CF6 module and loaded the module position in the article.

The beste way to prevent these issues is to use the CF6 menu item. You could hide this and link to it from within your article/ item. The form wille be openend in a new page, not inside your article. If you do need the form to be inside the article maybe Max could investigate the issue with the plugin and the cache and try top solve this somehow. Or you could turn the caching off. Or maybe use a caching component that gives you some more control over what pages are cached.

Jip.
Y
yorai85
Hi Jip, thanks for the info.

you described it well - the menu items work perfect but the module/plugin not.
did you have that issue on the core joomla content component?
on my site, clearing the k2-cach was enough to temporarly solve it, so i'm guessing it's k2's cach to blame.

by the way i did not try a regular module in a module-position, but i used "modules anywhere" plugin to call the CF6 module. when that caused the mentioned error, i tried the plugin but that caused the same error. also, the Page Cach plugin is turned off. the problem is caused by the Joomla cach, but turning that off is not an option...

hopefully the CE team will have an answer.
yorai
jj135
Hi Yorai,

Yes I had this issue with the core Joomla cache. We do not use K2. Clearing the cache does fix the issue, until te cache is filled again, so immediately after the first load of the page. The first load is OK, an reload of the page not.

Not sure if this is an issue caused by the Joomla or K2 caching mechanisme or by CF6...
Y
yorai85
just updating that i found a solution for this problem: instead of loading the form with a CF plugin, i created a CF module of the form, and set it's advanced paramater to "no caching".
then i loaded the module with the "modules anywhere" plugin.
now the form is loading correctly even if the cach is not empty.

UPDATE: this fix only worked on 1 of my websites, a 2nd website is still experiencing that problem, event with the module.

2nd UPDATE: the issue is now fixed on my 2nd website as well, after changing the configuration of the "modules anywhere" plugin - i changed "ignore chaching" from "yes" to "no".