Buy Now
Sign in

Which version of Chronoform do I need for Joomla 3.8?

qamar0786 , October 11 at 17:15
q
qamar0786

Hello,
My website was developed by a Freelance developer using Chronoform (v4.0.6) using Joomla 2.5. It was later upgraded to Joomla 3.6 under PHP 5.4, but I no longer have contact with the original developer.
Therefore, in order for me to upgrade the website to the latest Joomla and PHP versions (J!3.8/PHP 7.0), please advise me if I need to upgrade to Chronoform 6 or will the CF4 form continue to work under Joomla 3.8/PHP 7.0?
If I need to upgrade to Chronoform 6, will my CF4 form continue to work under CF6 or do I need to update my CF4 forms too?
Any help or documentation to answer these questions ASAP will be highly appreciated!
Many thanks

GreyHead

Hi qamar0786,

ChronoForms v4 still appears to run correctly on Jooma 3.8 and PHP 7. You will need to install the latest release of CFv4 though - you can just download that here and install it over the existing version.

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

q
qamar0786

Hi Bob,
Thanks for the reply.
The latest CF4 seems to be the one below (and mine says v4.0.6):

    Chronoforms_V4.0.7_J3.zip - 20-07-2016
    The main extension, must be installed.

https://www.chronoengine.com/chronoforms/download
What exactly is the difference between v4.0,6 and v4.0.7 please?
Thanks,
Qamar Uddin

q
qamar0786

GreyHead:

Hi qamar0786,

ChronoForms v4 still appears to run correctly on Jooma 3.8 and PHP 7. You will need to install the latest release of CFv4 though - you can just download that here and install it over the existing version.

Bob



*** TEST UPDATE ***
Hi Bob,

I have tested my website by updating to CF4.0.7 as per your suggestion above and the forms seem to work fine under Joomla 3.6.0 (PHP 5.6 & 7.0).
I then updated Joomla to v3.6.5 (next security update before 3.8.1), but the website was broken (blank/white page), so before restoring back to J!3.6, I tried updating Joomla to next version (J!3.8.1) and the website came back live again, but the CF4 form (using a custom module) was broken (blank/white page).
I then restored the website to J!3.6 with the latest CF4 as that seems to work fine at the moment.

But, I am in doubt whether all my CF4 forms will fully work under latest version of Joomla or not?
Any further advice/suggestion on the best version of Chronoform to use under latest Joomla version will be much appreciated.

Regards,
Qamar Uddin

admin

Hi Qamar,

It's always best to use the latest Chronoforms version with the latest Joomla version!

Best regards,
Max

Max
If your main question got answered then please mark the answer using the button!

q
qamar0786

admin:

Hi Qamar,

It's always best to use the latest Chronoforms version with the latest Joomla version!

Best regards,
Max



Hi Max,
This sounds like a very good idea, so what's the best way to go about importing my existing CF4 form into new CF6 installation, before I "uninstall" CF4 (if that's possible)?
Thanks,
Qamar Uddin

admin

Hi Qamar,

There is no way to import v4 forms to v6, you will have to rebuild the forms using the new version since the latest version uses a different database structure to store forms data.

Best regards,
Max

Max
If your main question got answered then please mark the answer using the button!